Stock kernels

Tom 'spot' Callaway tcallawa at redhat.com
Wed Aug 20 01:49:54 UTC 2003


On Tue, 2003-08-19 at 16:59, dsavage at peaknet.net wrote:

> 2.4:  A simple re-create to prove 'make rpm' works. No joy. :-(
> 
> A gcc thing??

I don't have a Severn system handy, but I tested 'make rpm' on my laptop
running RHL 9. I built up a 2.4.22rc2 kernel source tree, ran make
mrproper, copied the Severn i686 config into .config, then ran make
oldconfig. It stopped at two points, for drivers added into the kernel
tree after Severn's kernel. I set them both to M for kicks. I then ran
make dep, just for good measure. At this point, I ran make rpm. It
failed right at the end, when it tried to generate the debugfiles. You
probably don't need debugfiles, so I patched  scripts/mkspec to disable
that. After the patch, make rpm worked like a charm. (Patch is attached
to this email).

Now, if this fails in Severn, it is most likely a GCC issue. You may
want to set CC=gcc32 before building. There's nothing wrong with the
Severn config or 'make rpm' in the kernel source (with the exception of
the debugfiles issue).

~spot
---
Tom "spot" Callaway <tcallawa(a)redhat*com> SAIR LCA, RHCE
Red Hat Enterprise Architect :: http://www.redhat.com
Project Leader for Aurora Sparc Linux :: http://auroralinux.org
GPG: D786 8B22 D9DB 1F8B 4AB7  448E 3C5E 99AD 9305 4260

The words and opinions reflected in this message do not necessarily
reflect those of my employer, Red Hat, and belong solely to me.

"Immature poets borrow, mature poets steal." --- T. S. Eliot
-------------- next part --------------
--- linux-2.4.21/scripts/mkspec.BAD	2003-08-19 19:25:33.000000000 -0500
+++ linux-2.4.21/scripts/mkspec	2003-08-19 19:26:13.000000000 -0500
@@ -37,6 +37,7 @@
 echo "BuildRoot: /var/tmp/%{name}-%{PACKAGE_VERSION}-root"
 echo "Provides: $PROVIDES"
 echo "%define __spec_install_post /usr/lib/rpm/brp-compress || :"
+echo "%define debug_package %{nil}"
 echo ""
 echo "%description"
 echo "The Linux Kernel, the operating system core itself"


More information about the test mailing list