Severn/Shrike CUPS interop failure

John Kodis kodis at
Sun Jul 27 00:35:04 UTC 2003

I've already bugzilla'd this CUPS remote printing problem under
"Severn/Shrike CUPS interop failure" as bugzilla entry #100913,
<> but I
thought I'd ask here to see what results other people have had when
setting up remote printing.  Here's the description of my problem:

    I have an HP LJ3P printer connected to the parallel port on a
    machine running RHL9 and CUPS.  This works fine.

    I have also set up another RHL9 machine on my LAN to use CUPS, and
    to print to the remote HP LJ3P printer on the first machine.  This
    also works fine.

    When I try to configure a third PC running the Severn beta to
    access this same HP LJ3P printer, things are no longer so fine.

    In the redhat-config-printer window on the severn PC, the remote
    printer shows up under the "Browsed queues" tree, and the
    description of the printer matches what I entered on the first PC
    to which the printer is connected.  However, I am unable to set
    this queue up.  The edit, delete, default, sharing, delete, and
    apply actions are all inactive.

    When I force the issue by manually setting up a print queue using
    the same parameters as I used to successfully set up access to the
    remote printer from the second PC as described, any attempt to
    print a test page results in an Error dialog box that says

       There was a problem sending ASCII text test page to 'hp' queue:
       lpr: unable to print file: server-error-service-unavailable

    Now here's the odd part: I had been running tcpdump on the severn
    box during this whole time, and there was never any network
    traffic sent.  The only traffic was the udp packets broadcast from
    the machine with the printer to every 30

I've tried disabling all packet filtering, restarting all the cups
daemons, and all the other things that I could think of without any
change.  If anyone else has tried this or a similar setup, I'd
appreciate any success or failure reports.

John Kodis                                    Goddard Space Flight Center
kodis at                      Greenbelt, Maryland, USA
Phone: 301-286-7376                                     Fax: 301-286-1771

More information about the test mailing list