PHP4 + Apache2 = Experimental

Lance Davis lance at
Tue Jul 29 17:11:16 UTC 2003

On Mon, 28 Jul 2003, Marc Richards wrote:

> > I had no problems at all with PHP and Apache2. For what I know, it is
> widely used, although it may be labeled "experimental" I think it is quite
> reliable.
> > Note that PHP 4.3.2 (which was released by the end of May) includes a
> totally rewritten apxs2 support. It is worth trying.

apache 2 itself isnt really ready for production and it has been a pain 
since rh decided to include it in rh 8.0 


suexec / running cgi as different user/group in different virtual hosts  

replacement in Apache 2.0  is the perchild MPM


This MPM does not currently work on most platforms. Work is ongoing to 
make it functional.


Apparently it has now been dropped in favour of something else, that has 
also not been written yet ....

-- - The ISP of choice for the discerning Linux user. 

More information about the test mailing list