File system corruption with Severn

Jean-Francois Bélanger jef at
Wed Jul 30 03:03:34 UTC 2003

On Tue, 2003-07-29 at 21:57, djh wrote:
> On 28 Jul 2003, Jean-Francois wrote:
> > 
> > I've got file system corruption using Severn twice, some time after the
> > installation, I'm using a  PII-800 with a Intel 440ZX chipset based
> > board, and a Quantum 40Gig hd. After repaired the filesystem, I've got a
> > ton of error messages in the messages log:
> > 
> > hda: task_no_data_intr: status 0x51
> > hda: task_no_data_intr: error 0x04
> I'm seeing that as well (errors and fs corruption) on an old Athlon system 
> of mine, with and without ACPI.
> (Via KT133, onboard Promise ata100 and VIA ata66, Quantum 40G hd)
> > With RedHat 5,2 to 9.0 never had any problems on this computer, it was
> > very stable, now very unstable.  I've got strange message too, when
> > trying to execute something, it said something like unable to execute
> > binary file when I tried to run some command, then I restarted the
> > system and the file executed perfectly.
> That happens after ext3 gives up on it.  ("Journal has aborted")
> Will add something to bugzilla later today.
> David.
> --
> Rhl-beta-list mailing list
> Rhl-beta-list at

While in rescue mode from the cd, I've tried to check the disk with the
command: dd if=/dev/hda | wc -c 
Everything worked fine, no error, no messages.

I've just switched the hard disk with a smaller one. Seem to work fine
for now.  I've experienced some lockup too, but that must be my old

The corruption appeared while doing a lot of file transfer, i tried to
disable the dma for the drive but the corruption appeared anyway. 

More information about the test mailing list