FC2 Upgrade (how I resolved USB, Samba, and sound problems)

Erich Hoover ehoover at mines.edu
Sun Feb 15 19:48:09 UTC 2004


When I upgraded to the FC2 Test I ran into four major problems:
1) My USB didn't work (since I have a USB mouse this is important)
2) Samba mounts no-longer worked (reported the error "smbfs not 
supported by kernel")
3) My sound card drivers didn't load
4) My ATI All-In-Wonder 9800 Driver won't compile so 3D acceleration is 
disabled [unresolved]

Solution to number one:
* Open /etc/modprobe.conf.dist in an editor (or modprobe.conf - my 
modprobe.conf just forwarded to my modprobe.conf.dist)
* Add the line "alias usb-controller uhci-hcd"
* For some reason (at least for me) the usb controller was not setup to 
load because that line was missing

Solution to number two:
* Change directory to your linux source (for me this was 
/usr/src/linux-2.6.2-1.79/)
* run "make menuconfig" and locate the samba file system in the menus, 
turn it into a module
* recompile the kernel
* copy smbfs.ko from <linux source>/fs/smbfs/ to <linux 
modules>/kernel/fs/smbfs/ (for my linux modules was 
/lib/modules/2.6.1-1.65)
* modprobe smbfs

Solution to number three:
* Open /etc/modprobe.conf.dist in an editor (see solution to 1 for note)
* Add the appropriate lines for your sound card, this information is 
available at the ALSA website (http://www.alsa-project.org/alsa-doc/)
* Restart

Solution to number four:
* I haven't solved this one, if someone knows how to get the AIW 9800 
driver to compile I'd really appreciate help with it
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.fedoraproject.org/pipermail/test/attachments/20040215/7fd55298/attachment.html 


More information about the test mailing list