x86_64 Branch of the 1.90 Tree

Boszormenyi Zoltan zboszor at freemail.hu
Thu Mar 4 07:47:51 UTC 2004

lewt at warcry.com írta:
> I've never done a net install.. anyone know a good writeup?
> Thanks

Here's what I did for FC1 in a nutshell:

1. Download the whole tree (not the iso files) into a directory.
I used the following:
rsync -avr rsync://mirrors.kernel.org/fedora/core/1/i386/os/ \

2. Export this directory for the local clients by NFS/FTP/HTTP
(the method by which you want to install). I used NFS.

3. Make sure you have dhcp and tftp-server installed.
Set them up correctly. I have this in /etc/dhcpd.conf:

ddns-update-style interim;
ignore client-updates;
subnet netmask {
         allow booting;
         allow bootp;

# --- default gateway
         option routers        ;
         option subnet-mask    ;

         option domain-name              "localdomain";
         option domain-name-servers;

         option time-offset              -18000; # Eastern Standard Time

         range dynamic-bootp;
         default-lease-time 21600;
         max-lease-time 43200;

         filename "linux-install/pxelinux.0";
         host ns {
                 hardware ethernet 00:50:BF:7D:4E:F4;

It is important that you have the internal subnet explicitely
described (and only that), otherwise dhcpd will listen and
serve (or try to serve) addresses on every ethernet.
My ADSL provider does not like that. :-)

    My /etc/xinetd.d/tftp is this, I don't remember whether I made
    any changes to it:

# default: off
# description: The tftp server serves files using the trivial file transfer \
#       protocol.  The tftp protocol is often used to boot diskless \
#       workstations, download configuration files to network-aware printers, \
#       and to start the installation process for some operating systems.
service tftp
         disable = no
         socket_type             = dgram
         protocol                = udp
         wait                    = yes
         user                    = root
         server                  = /usr/sbin/in.tftpd
         server_args             = -s /tftpboot
         per_source              = 11
         cps                     = 100 2
         flags                   = IPv4

    You can enable/start them with System Settings/Server Settings/Services.
    The "disable = no" line in /etc/xinetd.d/tftp is set by that.

4. Start System Settings/Server settings/Network Booting Service
With this, you can set up both a networked installation and a network
bootable system. Its help is very clear what to do. Three things worth
- the name (not the description) you use for the networked installation
   should not contain spaces.
- the server address should be its local address, the default is using
   the address of eth0 (which was wrong in my case)
- after setting it up, go (as root) into /tftpboot and make a symlink
   from /tftpboot/linux-install/<Name you gave to the netinstall>
   into /tftpboot/<Name you gave to the netinstall> so the tftp server
   can correctly serve the vmlinuz and initrd the clients ask.

That said, this was done on an FC1, both dhcpd and tftpd runs on the
same machine, serving a FC1 netinstall.

I tried the same for FC2 (both for i386 and x86_64)
two days after FC2test1 came out but it did not work!

The i386 version did not work because the NFS install on the client
wanted iso images from the exported directory (yes, I tried the
"askmethod" option), the x86_64 version did not work because either
the r8169 driver or the dhcp client code did not work in 64 bit mode.
Both was on the same machine with an MSI K8T Neo FIS2R mainboard.
I am going to test it again next week. The PXE boot rom code works
correctly after upgrading to BIOS v1.2, before that I burned boot.iso
into an CD-RW disk.

Best regards,
Zoltán Böszörményi

What did Hussein say about his knife?
One in Bush worth two in the hand.

More information about the test mailing list