Another person's experience installing FC2 test 2

shmuel siegel fedora at
Wed Mar 31 17:21:26 UTC 2004

I tried two things at the same time. Not enabling selinux and not using
reiserfs. Together this let me run the fc2. Very strange that the file
system should make a difference. I had also initially tried reiserfs
with warn mode for selinux.

I was going to report the problem but then noticed
where Bill Nottingham says 
"reiserfs does not support extended attributes, so SELinux will not
work with it."

so I guess that it is the file system.

On Wed, 2004-03-31 at 14:19, Aled Hughes wrote:
> I too had exactly the same problem with missing inittab and also various
> rc.* scripts. Initially I had this with a rawhide version just prior to
> test2, but after getting test2 and installing onto an empty existing
> reiserfs partition, it still happened. I had SELinux in 'warn' mode.
> When I reinstalled and told it to reformat the root partition as ext3 the
> init problem was resolved. So I concluded the problem is related to using
> reiserfs.
> My system still doesn't boot correctly (sticks at "updating etc/fstab"), but
> that's an unrelated issue I need to further investiage.
> -----Original Message-----
> From: fedora-test-list-bounces at
> [mailto:fedora-test-list-bounces at]On Behalf Of shmuel siegel
> Sent: 31 March 2004 03:01
> To: For testers of Fedora Core development releases
> Subject: Another person's experience installing FC2 test 2
> I am running a dual boot Win2k/Fedora system. Originally formatted by
> Win2k for the NTFS and Fat32 partitions and formatted by RH7/8/9 for the
> ext3 and linux swap partitions.
> I got the already known complaints during the install. I couldn't do a
> hard disk install because I didn't have a driver. The CDROM install
> warned about partition alignment problems.
> I didn't upgrade my FC1 system but rather installed FC2 to an existing
> ext3 partition which I bravely reformatted as reiserfs. The installation
> went smoothly and rapidly.
> Rebooting, I found to my annoyance, that the boot loader was overridden
> and now pointed to somewhere that didn't have my fc1 configuration, thus
> forcing me to do some grub.conf editting. But more seriously, with
> selinux turned on, I couldn't start. init did not have the proper
> permissions. Rebooting with selinux turned off, didn't help since there
> was no inittab. Copying the inittab from fc1 didn't help since there was
> no rc.d/rc.
> How should I proceed?
> --
> fedora-test-list mailing list
> fedora-test-list at
> To unsubscribe:

More information about the test mailing list