FC3 does not boot with an own vanilla kernel

RON FLORY ron.flory at adtran.com
Wed Nov 10 18:34:08 UTC 2004

> On Wed, 2004-11-10 at 15:52 +0100, Joachim Backes wrote:
>>I made an update from FC2 to FC3, and now, my machine will no more boot:
>>The boot stops when executing the init scripts:
>>having problems with the /dev directory (cannot open /dev//null and/or
>>/dev//console).  I'm not using the FC3 kernel, but the vanilla kernel
>>2.6.9. When using the FC3 kernel, all is OK. I think, it has
>>to do with udev (in my vanilla kernel, hotplug is configered

  I've seen this as well- have been unable to get FC3* to run
under a vanilla kernel.org kernel.  When i disable the 'quiet' flag
in grub, the boot process aborts with something like 'unable to open

  I never reported it because I thought i was missing something
obvious- i guess I'm not the only one.

Arjan van de Ven wrote:
> did you also make an initrd?
> (if you used "make install" in the kernel tree one should have been
> created for you automatically, as well as it being added to grub
> automatically)

  I know I did when I tried it, except i run mkinitrd manually.

  Could this have something to do with udev?  I noticed that if
I enabled the deprecated /dev FS, it broke in a slightly different
manner.  I suspect the problem is the FC3 environment expects a
magic combination of kernel options- I just have not been able to
stumble upon them yet...


More information about the test mailing list