yum-2.1.11-4 not playing well with python-2.4-0.b2.1

seth vidal skvidal at phy.duke.edu
Sun Nov 14 02:22:59 UTC 2004


On Sun, 2004-11-14 at 10:52 +1300, Mark Derricutt wrote:
> seth vidal wrote:
> 
> >>a fix is here
> >>https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=138535
> >>
> > No, that's not a good fix. It patches python, that's probably not the
> > best place, despite the fact that it looks like a backward compat break.
> > -sv
> 
> Seth - has anything further been done on this?
> 
> Another "fix" which isn't entirely a good fix would be to have a new 
> build of yum that did a version check on urllib and acted appropriately 
> ( better than a new yum which explicitly requires the newer 
> python/urllib, but not by much ).
> 
> That being said, I'm sure this urllib change will be breaking more than 
> just yum so patching just 'yum' isn't a solution either.
> 
> Has this been bugzilla'd with fedora or upstream with python at all?
> 

No, It's been refiled as a python bug. I'm not sure of its status right
now.

-sv





More information about the test mailing list