Using Sun's JRE 1.5.0-3 next to java-1.4.2-gcj?

Mary Ellen Foster mefoster at
Mon May 16 14:57:20 UTC 2005

On 5/16/05, Patrick <fedora at> wrote:
> Apps like Azureus, Ganttchart and CentricCRM won't run (yet) with
> jre-1.4.2-gcj so I would like to use Sun's JRE 1.5.0-3. Anyone have a
> suggestion how I can force those apps to use Sun's JRE installed in
> e.g. /opt/java. Setting PATH=/opt/java:$PATH and JAVA_HOME=/opt/java
> doesn't work.

You should try rebuilding the Jpackage "nosrc" rpm of the Sun JRE and
installing that, instead of using the JRE directly -- instructions at

Once you've done that, you can change where the "alternatives" link
for java as follows (as root):
    /usr/sbin/alternatives --set java /usr/lib/jvm/jre-1.5.0-sun/bin/java

Then "/usr/bin/java" will be the Sun JRE, and all your apps should use
it by default.

There's no GUI config tool for alternatives, is there; it would be nice ...


__ Mary Ellen Foster __ __
"One of the main causes of the fall of the Roman Empire was that, 
lacking zero, they had no way to indicate successful termination 
of their C programs." (Robert Firth)

More information about the test mailing list