Can't Get Past X dependencies

Paul Dickson paul at
Fri Nov 18 23:29:01 UTC 2005

On Fri, 18 Nov 2005 08:54:49 -0500, Clyde E. Kunkel wrote:

> Maybe someone can provide a little help or direction.  I have read all 
> of the messages on this list and the development list this week but 
> still can't get past the following (from yumex output) when trying to 
> update to latest rawhide.
> ['fontconfig conflicts with fonts-xorg-base',
> 'Missing Dependency: /usr/X11R6/bin/mkfontdir is needed by package 
> xorg-x11',
> 'Missing Dependency: xorg-x11-xfs = 6.8.2-62 is needed by package 
> xorg-x11',
> 'Missing Dependency: xinitrc is needed by package xorg-x11',
> 'Missing Dependency: xorg-x11 is needed by package xorg-x11-tools', 
> 'Missing Dependency: xorg-x11 = 6.8.2-62 is needed by package 
> xorg-x11-Xnest']
> I deselected fontconfig and that conflict goes away, but the others remain.

I didn't have much a problem.  Just a few rpms (4) that have not been
updated to the latest openssl and maybe one rpm dependent on the old
xorg-x11.  For the openssl I downloaded the spec file for openssl097f
(found in bugzilla) and compiled/installed it.  This allowed be to
continue updating (but I still monitor for updates to these rpms so I can
get rid of openssl097f.  Remaining is grip, hdf5, libesmtp, and
scribus).  I just deleted the xorg-x11 blocking rpms and reinstalled some
of them last night when their updates appeared (openmotif, xpdf).

Perhaps you can show us what repositories you're using?

Also list all of your conflicts.  Maybe some can suggest what you need to
do.  As your message stands, it doesn't provide much info other than "it
don't work"(tm).


More information about the test mailing list