No floppy (or CD/DVD) after install

Thomas Taylor linxt at
Mon Feb 6 22:26:56 UTC 2006

Hi David:

On Monday 06 February 2006 04:02, David Timms wrote:
> Thomas Taylor wrote:
> >I have installed FC5.2 on my computer 3 times now.  Each time the nodes
> >for /media/floppy and /media/cdrecorder are not being created.  The /media
> >directory is there but it's empty.
> I think I read somewhere that it is udev's job to create the folders
> under /media/ as removable media is detected and removed. Currently my
> /media directory on FC5t2 + updates is empty as well.

The folders are not being created and there are no entries for either device 
in either /etc/fstab or /etc/mtab.

> If I stick in a DVD video, a folder with the title of the DVD (eg
> Planet_Of_The_Apes), and also totem tries to play it, but given FC has
> no mpeg decoder, it just gives an error message. Also, a desktop icon
> with the title is created: I use this to eject to DVD from the context
> menu.
> >...
> >Looking in bugzilla, I found bug 177589 which is similar but doesn't
> > provide me with any insight into my problem.
> >
> >I haven't been able to use mknod because I don't have the major/minor
> > numbers for these devices.  When I tried to download the source code per
> > the instructions in the release notes, it failed.
> Floppy disk insertion is not detectable; instead nautilus Computer shows
> Floppy Drive. Context menu Mount Volume displays a small dialog with an
> X, but no text, then another error dialog is shown over the top "Error"
> "X Unable to mount media. There is probably no media in the drive". This
> is shown immediately, without lighting the FDD LED (I understand that
> accessing the disk is the only way to detect if there is a disk in the
> drive, and this is _not_ being done).
> if I su and:
> mount /dev/fd0 /mnt
> the disk is mounted OK and double clicking the Floppy Drive entry shows
> the contents of the disk OK, and a desktop icon is shown with the title
> mnt !?! (perhaps if the disk has no title, then it causes a problem for
> the current code ?)
> Neither of the context menus on for unmount manage to unmount the disk.
> df displays an error:
> df: '/mnt': Input/output error
> # umount /dev/fd0
> is successful at dismounting the disk.
> >Can someone please send me the major/minor numbers for those devices or
> >provide some other way to access them.
> Can you try the tests I tried above, and respond here ?
> If no help, maybe useful : ?
> # ll /dev/{cd*,fd0}
> lrwxrwxrwx 1 root root        3 (date time) /dev/cdrom -> hdc
> lrwxrwxrwx 1 root root        3 (date time) /dev/cdwriter -> hdc
> brw-rw---- 1 dave floppy 2,   0 (date time) /dev/fd0
> DaveT.

[root at linux2 ~]# mount /dev/fd0 /mnt
[root at linux2 ~]# umount /mnt
[root at linux2 ~]# mount /dev/hdc /mnt
mount: block device /dev/hdc is write-protected, mounting read-only
[root at linux2 ~]# df /mnt
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hdc                 11002     11002         0 100% /mnt
[root at linux2 ~]# ll /dev/{cd*,fd0}
lrwxrwxrwx 1 root root      3 Feb  5 00:45 /dev/cdrom -> hdc
lrwxrwxrwx 1 root root      3 Feb  5 00:45 /dev/cdwriter -> hdc
brw-rw---- 1 tom  floppy 2, 0 Feb  5 00:46 /dev/fd0

The devices can be mounted via cli as shown above.  The automounter doesn't 
seem to be working as the cdrom is not spun up when a cd is placed into it.  
When I try to use the icon, right clicking and selecting mount, I get the 
message "could not mount device - the reported error was: mount: can't 
find /media/floppy(cdrecorder) in /etc/fstab or /etc/mtab."

Contents of /etc/fstab:
LABEL=/                 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
LABEL=/downloads        /downloads              ext3    defaults        1 2
LABEL=/home1            /home                   ext3    defaults        1 2
proc                    /proc                   proc    defaults        0 0
LABEL=/source           /source                 ext3    defaults        1 2
sysfs                   /sys                    sysfs   defaults        0 0
LABEL=/temp1            /temp1                  ext3    defaults        1 2
LABEL=/temp2            /temp2                  ext3    defaults        1 2
LABEL=/usr              /usr                    ext3    defaults        1 2
LABEL=/var              /var                    ext3    defaults        1 2
LABEL=SWAP-hdb5         swap                    swap    defaults        0 0

Contents of /etc/mtab:
/dev/hda6 / ext3 rw 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
/dev/hda1 /boot ext3 rw 0 0
tmpfs /dev/shm tmpfs rw 0 0
/dev/hdb1 /downloads ext3 rw 0 0
/dev/hda5 /home ext3 rw 0 0
/dev/hda3 /source ext3 rw 0 0
/dev/hdb2 /temp1 ext3 rw 0 0
/dev/hdb3 /temp2 ext3 rw 0 0
/dev/hda2 /usr ext3 rw 0 0
/dev/hdb6 /var ext3 rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0
automount(pid1982) /net autofs rw,fd=4,pgrp=1982,minproto=2,maxproto=4 0 0

As you can see, no entry for either device has been created in either file.  
What I want to do is create those entries and the links for them.  Is that 
the correct approach, or is there a better way.  

I suspect something is may be unusual about my hardware or it should have been 

Gigabyte GA-7DPXDW+ m/b with two AMD cpus
ATI RV280 (radeon 9200)
Plextor PX-708 CD/DVD recorder
Iomega ZIP 750 ATAPI (which also doesn't show up)
WDC WD1200JB (x2) hard drives
Ethernet Pro 100
Adaptec 160 scsi card
Seagate AIT tape drive (not showing)


Tom Taylor
Linux user #263467
Federal Way, WA

More information about the test mailing list