conflicting i86 and x86_64 in repo?

Jesse Keating jkeating at
Fri Jul 14 13:03:41 UTC 2006

On Friday 14 July 2006 08:57, tomhorsley at wrote:
> Has pup screwed up at some point and installed i386 rpms when it should
> have picked x86_64 ones? Have the repos gotten corrupted at some point?
> Or is it really legitimate to have two conflicting rpms like this?

Yum, which pup users, will install both the i386 and the x86_64 version of a 
package if you request to install "package".  This ensures that you have a 
proper environment for running 32 bit software if need be.

If there is a conflict between the i386 and the x86_64 version of a package 
provided in the x86_64 repository, then there is a bug in said package.  If 
the package is supplied multiarch it must not have any conflicts.

Jesse Keating
Release Engineer: Fedora
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : 

More information about the test mailing list