network problems after installation

Mike Chambers mike at miketc.com
Fri Apr 18 23:27:16 UTC 2008


On Fri, 2008-04-18 at 23:20 +0100, Andrew Cannon wrote:
> Hi All,
> 
> I too have had numerous problems with Networking.  My setup is a simple
> home network with a router connecting me to the internet via eth0.  Now,
> my problem is that the network is not getting activated on boot (despite
> me having ifcfg-eth0 set to start the interface at boot.  I've used
> NetworkManager (which I detest) and that didn't work (it overwrote the
> DNS entries so I could not communicate with the rest of the world) I've
> set everything to be static, I've tried DHCP and I still can't get the
> network to initialize until I manually bring the network up with
> /sbin/ifup eth0.

To use NM, edit /etc/sysconfig/network-scripts/ifcfg-eth0 and make sure
below is there..

NM_CONTROLLED=yes
search=dnsdomain.to.search
DNS1=1.2.3.4 (Add more dns entries if need be)

And make sure network service, and any other wireless/network services
are OFF, except for NM itself, nothing else.  Do not
use /etc/resolv.conf as NM will remove the contents.

You may have tried all of these, if so then sorry to have bothered ya.
Hope ya get it going.

-- 
Mike Chambers
Fedora Project - Ambassador, Bug Zapper, Tester, User, etc..
mikec302 at fedoraproject.org




More information about the test mailing list