/root encryption is still broken

Bruno Wolff III bruno at wolff.to
Sat Mar 1 04:09:15 UTC 2008

On Fri, Feb 29, 2008 at 20:47:59 -0500,
  Jeremy Katz <katzj at redhat.com> wrote:
> On Fri, 2008-02-29 at 10:59 -0600, Bruno Wolff III wrote:
> > On Thu, Feb 28, 2008 at 12:17:27 -0500,  Will Woods <wwoods at redhat.com> wrote:
> > > 
> > > It's bug 435228.
> > 
> > I took a look at the info you had, and will try to figure out some way to use
> > it. Unfortunately on a fresh install, you can't (as far as I can tell) get
> > a vt after the install is complete (before rebooting) in order to rerun
> > mkinitrd. 
> VT switch was working for me on Wednesday -- has it been broken (...
> again)?

I couldn't use it at the end of an install, I had been able to switch during
and install, but I am not sure if it was the same image though. It may be
that that particular image had a problem that would be there now.

Unfortunately I could wait around work for the install to finish today, but
it should be at the reboot prompt when I get in on Monday and I can try it

> > Today's rawhide isn't out yet, so I am going to take a look and see if I can
> > figure out if a patch got applied already. It might be easier to just wait
> > for the rawhide push if that's the case. Otherwise there probably is a
> > way to do it with a rescue disk.
> The patch hasn't been pushed into mkinitrd yet and there was still some
> back and forth as to what works and what doesn't I believe...

That's the conclusion I came to after checking koji. Koji is pretty neat.
I won't be able to try again until Monday.

More information about the test mailing list