How do you clear a botched kernel on a PPC system?

Joel Rees joel.rees at
Sat Sep 26 10:19:45 UTC 2009

I find myself in another nice catch 22.

Some time last week, I updated with yum (after several weeks of not  
updating) and, for some reason, I was able to reboot that day, but  
the next day attempting to boot Fedora resulted in a kernel panic.

Looking things up, I see I'm not the only one with a panicking kernel.

So, I got to work to clear the crudded kernel out of the way.

Took me a while of looking around the web to rediscover the  
incantation to get to rescue mode with an install CD: "linux rescue"  
at the second stage boot prompt.

Then I booted to rescue mode. I was thinking along the lines of, even  
though I don't get a grub menu like on x86, I should be able to  
change the configuration file to default to the previous kernel.

Is the usual approach to that to use ybin? (And it looks like, with  
all the strange parameters, and the success rate I'm having today  
with arcane command parameters, it would likely take several tries to  
get it right.)

Isn't there an easier way to do this?

I tried passing the kernel name of the previous kernel in at the  
second stage prompt, but, even though I figured out (again) the  
arcane open firmware syntax to point to the kernel:


(Since the boot volume is separate, the path to the kernel is empty.)

it tells me that I should try passing in the init= parameter. I tried  
several permutations of what I thought was the probable syntax,

boot: hd:3,/vmlinuz- init=/ 

and such, but all of them failed to execute, suggested specifying  
init= and left me at 180 seconds to reboot.

So I'm having a hard time with things today. Can someone put me out  
of my misery?

Joel Rees

More information about the test mailing list