Tried to install F14 Alpha in QEMU on F13; hang during boot

Bill Davidsen davidsen at
Mon Aug 30 21:12:46 UTC 2010

Eric Blake wrote:
> On 08/29/2010 02:16 PM, Matt McCutchen wrote:
>> I am eager to play with systemd, so I tried to install F14 Alpha x86_64
>> on a QEMU virtual machine.  The host is my Dell Latitude D620 running
>> F13 x86_64, fully updated with updates-testing enabled.  I started the
>> VM with this command (f14.qcow2 is a blank 4GiB disk image created with
>> qemu-img):
>> qemu-kvm -hda f14.qcow2 -cdrom Fedora-14-Alpha-x86_64-DVD.iso
> You may also want to consider using virt-install (command line) or 
> virt-manager (gui) for creating new VMs, since those are also Fedora 
> packages that attempt to make this easier.
> On 08/30/2010 09:35 AM, "Jóhann B. Guðmundsson" wrote:
>  >>> This is unlikely to work. I suggest to append "-m 512" to the start-up
>  >>> options in order to enable 512 MB of system memory. QEMU default value
>  >>> is 128 MB of system memory.
>  >> That was the problem.  Thanks.
>  >>
>  > Hum if this is a case perhaps it's best to file a bug report and ask for
>  > the default value to be increased to 512 MB
> I know that virt-manager has a 512MB default, but am not sure whether 
> virt-install has the same default as qemu, or whether this warrants a 
> bug report for both qemu and virt-install.
If the installer requires 512MB it's not sane to expect every hypervisor to 
increase the default just in case someone tries to install Fedora. The bug is in 
the (lack of) error checking in the installer.

Bill Davidsen <davidsen at>
   "We have more to fear from the bungling of the incompetent than from
the machinations of the wicked."  - from Slashdot

More information about the test mailing list