Fedora 14 alpha installation scrambles disk ids

Gerry Tool gerry at thetoolshed.us
Tue Aug 31 03:52:59 UTC 2010

I have been trying to install F14 alpha.  When I do, the hard drives are not
identified as they have been in the past.  I have two hard drives, one with
233GB and one with 149GB.  l have a number of partitions on each drive with
operating systems on them.  The 233GB has always been identified as hd0 in
the past.  F14 alpha insists it is hd1 with the 149GB being hd0.  The dev
ids are also messed up.  the 233GB has always been sda.  Now, F14 evidently
starts the sd numbers with one of the USB devices.  I have a multi-card
reader hard-wired inside the box, and it is apparently labelling its
channels as sda - sdd.  I have two external USB drives, which until I
unplugged them were being identified as sde, sdf, moving the first (formerly
second) harddrive up to sdg and the old sda to sdh.

If I let the installation proceed, it seems to succeed, but I can not find a
way to get the F14 alpha system to boot using my long-standing boot loader
setup controlled by my current F13 partition.  I have tried

title Fedora 14 alpha
    rootnoverify (hd0,2)
    chainloader +1

using a variety of (hdx,y) attempts, and have also tried several variations
of the grub.conf file in the new F14 alpha configuration.

How can I tame this mess?


Gerry Tool
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.fedoraproject.org/pipermail/test/attachments/20100830/f4dbdc63/attachment.html 

More information about the test mailing list