Fedora 14 alpha installation scrambles disk ids

Mike Chambers mike at miketc.net
Tue Aug 31 09:03:50 UTC 2010

On Mon, 2010-08-30 at 22:52 -0500, Gerry Tool wrote:
> I have been trying to install F14 alpha.  When I do, the hard drives
> are not identified as they have been in the past.  I have two hard
> drives, one with 233GB and one with 149GB.  l have a number of
> partitions on each drive with operating systems on them.  The 233GB
> has always been identified as hd0 in the past.  F14 alpha insists it
> is hd1 with the 149GB being hd0.  The dev ids are also messed up.  the
> 233GB has always been sda.  Now, F14 evidently starts the sd numbers
> with one of the USB devices.  I have a multi-card reader hard-wired
> inside the box, and it is apparently labelling its channels as sda -
> sdd.  I have two external USB drives, which until I unplugged them
> were being identified as sde, sdf, moving the first (formerly second)
> harddrive up to sdg and the old sda to sdh.
> If I let the installation proceed, it seems to succeed, but I can not
> find a way to get the F14 alpha system to boot using my long-standing
> boot loader setup controlled by my current F13 partition.  I have
> tried
> title Fedora 14 alpha 
>     rootnoverify (hd0,2)
>     chainloader +1
> using a variety of (hdx,y) attempts, and have also tried several
> variations of the grub.conf file in the new F14 alpha configuration.

Dunno if this will help, but during install when it gets to the grub
selection part, make sure it is the same hdd order as your bios has it
listed and you can change it there too.  


More information about the test mailing list