F12 Testing highlight: new xorg-x11-server, mesa, libdrm and xorg-x11-drv-ati

Michael Breuer mbreuer at majjas.com
Sun Jan 10 17:32:59 UTC 2010

On 1/7/2010 9:40 AM, Adam Williamson wrote:
> Hi, folks. Just wanted to highlight some fairly major planned F12
> graphics updates going into updates-testing.
> I posted a testing request previously for xorg-x11-server, to get some
> preliminary testing before it went into the updates-testing repo. The
> feedback from that was positive, so a new xorg-x11-server - bumped up to
> 1.7.3 and with several other changes - is now in updates-testing.
> In addition, there's a new mesa package, with a significant version bump
> from 7.6 to 7.7. There's an accompanying libdrm update, and a
> significant update to xorg-x11-drv-ati (radeon), the driver for ATI/AMD
> graphics cards, with many bugfixes and changes.
> As graphics-related updates are prone to regressions and this a fairly
> major change when you add it all up, it would be extremely helpful if as
> many of you as possible could install these particular packages from F12
> updates-testing and check how they work for you. Please please report
> any noted regressions to Bodhi (preferable) or reply to this thread.
> Might also be helpful to know if they solve any problems anyone's been
> facing - they may address some 3D issues or improve performance,
> especially on ATI/AMD hardware. Thanks!
Ok - finally gave it a go. Much better than last time - a few things to 
note however...
(8800GTS, Asus p6t deluxe v2, 12Gb, I7 920, ht enabled, vt-d enabled, 
2.6.32-2 (git) nouveau (git), CONFIG_DMAR off)
1. Performance - seems slower by about 15% than current f12. glxgears, 
for example I get about 650FPS with F12, and about 520 with updates-testing.
2. Race on startup when booting directly to runlevel 5 with gdm & tty1 - 
100% Xorg cpu. Clears after restart of X, or if booting 3 then 5.
3. Reboot required after upgrade - telinit 3 && 5 yields no visible 
console. Even tried removing all fb mods and modprobe fbcon... chvt 
(1..6), etc... nothing. Keyboard worked, but no display. OK after reboot.

More information about the test mailing list