Pre-upgrade to F13Beta can't find my root filesystem

James Laska jlaska at
Wed May 5 19:57:45 UTC 2010

On Wed, 2010-05-05 at 14:44 -0400, Kevin J. Cummings wrote:
> On 05/04/2010 05:05 PM, James Laska wrote:
> > 
> > preupgrade is the automated process.  You'll likely need to get your
> > hands dirty to work around any issues that are resolved in newer
> > preupgrade releases.
> I can see that.  B^)
> > You can try building and running the latest preupgrade on your Fedora 10
> > system.
> Gives the same results.  I have the same 2 issues depending on which
> release I try and install:
> Fedora 11 or Fedora 12:
> preupgrade fails while setting up the repos.  It doesn't matter if I
> delete /boot/upgrade and /var/cache/yum/preupgrade* before I start or
> not.  (I'm probably missing something else here as it still asks me if I
> want to continue my previous attempt.)  The actual error is:
> If I hit the retry button, it immediately complains about repository
> preupgrade-main being listed more than once in the configuration.
> Fedora 13 Beta
> preupgrade chugs along, downloads the packages, sets up the reboot
> stuff, and lets me reboot.
> After rebooting (and selecting the Fedora 13 Branch if necessary), it
> starts up, brings up the Blue screen, starts Anaconda, starts up the X
> server, searches for storage devices, finds my 2 disk drives, and waits
> for me to select them and hit the forward button.  The minute I push it,
> it tells me that it is unable to find my previous root filesystem.  It
> doesn't matter if I mount it by hand on /mnt/sysimage myself or not
> before pushing the forward button.
> I did run it once with the loglevel=debug Anaconda option, and I noticed
> that the log says that Fredora 10 is not upgrade-able to this release in
> one of the DEBUG log messages.  I would have thought that this message
> should be printed directly to the user....
> What I have not yet tried is running with the "upgradeany" Anaconda
> option which is the last thing I will try.

Hmm, worth a try.  I'm not familiar with this aspect of the upgrade

> 	If I can't upgrade using preupgrade, will I be able to upgrade using
> the Fedora 13 i386 DVD upgrade process?  If so, what's the difference????

Yes.  Preupgrade is just another supported (but newer) upgrade method,
often a simpler method for upgrading an existing system.  Unfortunately,
you have the midas touch!

> Thanks for the help, I know most of you are crunching to get Fedora 13
> released....
> > Or, you can try playing with the boot arguments preupgrade setup.  I
> > don't have them listed in front of me at the moment, but you need to
> > tell the installer where to find the packages on disk (repo=), and where
> > to find the stage#2 install image (stage2=).
> Does it matter that the repo=hd::/var/cache/yum/preupgrade does not
> contain a disk identifier?  On my system, /var is a separate partition
> from either / or /boot.  I have tried changing it to:
> 	repo=hd:UUID=uuid:/cache/yum/preupgrade
> with no change in my problem (still can't find my previous root filesystem)

I've been told that is not a problem.  But I've not investigated in
detail yet.  I'd need to look at the anaconda/loader source code, or see
if one of the anaconda developers knows.

> > Acceptable values for both parameters are listed at
> >
> I read the document.  Thank-you.  Very informative.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
Url : 

More information about the test mailing list