Hang on boot in F13 RC2

Tommy He tommy.he at linux.com
Mon May 10 11:07:50 UTC 2010


Have you tried removing "rhgb" from the kernel boot parameters ?  I came to
a similar problem on an Intel Macbook couples of days ago in Intel Graphic
Testing Day. In that case, removing rhgb parameter or using KDE LiveCD (KDM
instead of GDM) works.

Currently I am running F13 on GeForce 8400M G, it works both with nouveau or
proprietary driver.

Regards,

On 10 May 2010 11:22, Brian C. Huffman <bhuffman at graze.net> wrote:

> On Mon, 2010-05-10 at 03:49 +0100, Adam Williamson wrote:
> > On Sun, 2010-05-09 at 17:42 -0400, Brian C. Huffman wrote:
> > > All,
> > >
> > > When booting from the F13 RC2 live CD, I get a complete hang (keyboard,
> > > video, etc) just before going into gdm.  The plymouth "F" has
> completely
> > > filled and I can see the new animated circular mouse cursor and then
> the
> > > cursor just freezes solid and the system is completely unresponsive.
> > >
> > > I have an nvidia GeForce 8400GS and I suspect nouveau somewhere between
> > > the DRM and X.  doing a "rdblacklist=nouveau nouveau.modeset=0" works.
> > >
> > > Same system works fine with Ubuntu 10.04 either nouveau or with
> nvidia's
> > > proprietary drivers.
> > >
> > > How can I help?
> >
> > It would *really* have helped if you'd told us earlier, for one thing -
> > basically, now, if we find a blocker bug, we have to slip the release a
> > week. The X stack hasn't changed since about last Wednesday, so this bug
> > must have been there then. :(
> >
> > But, aside from that if you see a cursor, then X has at least half
> > started, so - can you boot to runlevel 3, without the blacklisting /
> > disabling modeset stuff? If so, then do that, log in, run 'startx' and
> > note any errors, and also post /var/log/Xorg.0.log.old after rebooting.
> >
> > Ben, can you please take a look at this problem, and also maybe test RC2
> > on your stack of test machines? I don't actually have any NVIDIA systems
> > where I am now, though I think jlaska has probably tested on some.
> > Thanks.
>
> I don't think this should be a F13 blocker b/c it doesn't work with F12
> either.  And it doesn't seem to be exactly reproducible - I tried again
> to boot into F13_RC2 and it got past the login screen and then froze
> while bringing up the desktop.
>
> Honestly I think it has something to do w/ PCI Express on this
> motherboard (MSI P41-C31).  The same card works fine in another system
> with an Intel MB.
>
> -b
>
> --
> test mailing list
> test at lists.fedoraproject.org
> To unsubscribe:
> https://admin.fedoraproject.org/mailman/listinfo/test
>



-- 
Take a Deep Breath out of Windows
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.fedoraproject.org/pipermail/test/attachments/20100510/38c3a81c/attachment.html 


More information about the test mailing list