Fedora 12 updates-testing report

updates at fedoraproject.org updates at fedoraproject.org
Mon May 31 18:31:15 UTC 2010


The following builds have been pushed to Fedora 12 updates-testing

    3proxy-0.6.1-9.fc12
    abrt-1.1.1-1.fc12
    aldrin-0.13-4.fc12
    armstrong-0.2.6-11.fc12
    bdii-5.1.5-1.fc12
    calibre-0.6.55-1.fc12
    canorus-0.7-6.R1213.20100530svn.fc12
    cdf-0.2-3.fc12
    emacs-vm-8.1.1-1.fc12
    erlang-esasl-0.1-5.fc12
    gpodder-2.3-3.fc12
    grub2-1.98-2.fc12
    imapsync-1.311-1.fc12
    ircd-hybrid-7.2.3-11.fc12
    ircd-ratbox-2.2.8-7.fc12
    isdn4k-utils-3.2-71.fc12
    jaxodraw-2.0.1-5.fc12
    kicad-2010.05.27-2.rev2363.fc12
    kpartsplugin-0.0.1-0.2.20100521.fc12
    mozilla-noscript-1.9.9.81-1.fc12
    papyrus-0.13.3-1.fc12
    perlbrew-0.06-2.fc12
    pidgin-2.7.1-1.fc12
    rhythmbox-equalizer-1.4-1.fc12
    rkward-0.5.3-1.fc12
    roundup-1.4.13-2.fc12
    squid-3.1.4-1.fc12
    surfraw-2.2.7-1.fc12
    tinyproxy-1.8.1-1.fc12
    uzbl-0-0.13.20100410gitec473e124.fc12
    waf-1.5.17-1.fc12
    wordpress-plugin-bad-behavior-2.0.36-1.fc12
    wxPython-2.8.11.0-1.fc12
    xinha-0.96.1-1.fc12

Details about builds:


================================================================================
 3proxy-0.6.1-9.fc12 (FEDORA-2010-9281)
 Tiny but very powerful proxy
--------------------------------------------------------------------------------
Update Information:

Correct path to config file in man (BUG#596087) add Patch0: 3proxy-0.6.1-config-
path.patch
--------------------------------------------------------------------------------
ChangeLog:

* Sun May 30 2010 Pavel Alexeev <Pahan at Hubbitus.info> - 0.6.1-9
- Correct path to config file in man (BUG#596087) add Patch0: 3proxy-0.6.1-config-path.patch
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #596087 - Wrong path to 3proxy.cfg in /usr/share/man/man8/3proxy.8.gz
        https://bugzilla.redhat.com/show_bug.cgi?id=596087
--------------------------------------------------------------------------------


================================================================================
 abrt-1.1.1-1.fc12 (FEDORA-2010-9233)
 Automatic bug detection and reporting tool
--------------------------------------------------------------------------------
Update Information:

Here is where you give an explanation of your update.
--------------------------------------------------------------------------------
ChangeLog:

* Fri May 28 2010 Jiri Moskovcak <jmoskovc at redhat.com> 1.1.1-1
- removed avant-window-navigator from blacklist (jmoskovc at redhat.com)
- Abort debuginfo download if low on disk space (partially addresses #564451) (vda.linux at googlemail.com)
- fix bug 588945 - sparse core files performance hit (vda.linux at googlemail.com)
- Add BlackListedPaths option to abrt.conf. Fixes #582421 (vda.linux at googlemail.com)
- Do not die when /var/cache/abrt/*/uid does not contain a number (rhbz#580899) (kklic at redhat.com)
- rid of rewriting config in /etc/abrt/abrt.conf (npajkovs at redhat.com)
- fix bug 571411: backtrace attachment of the form /var/cache/abrt/foo-12345-67890/backtrace (vda.linux at googlemail.com)
- Do not echo password to terminal in abrt-cli (kklic at redhat.com)
- obsolete gnome-python2-bugbuddy rhbz#579748 (jmoskovc at redhat.com)
- removed unused patches
- updated transaltions
- added Hebrew into languages
- updated icons rhbz#587698 (jmoskovc at redhat.com)
- Bugzilla login/password emptiness check uses 'or' instead of 'and' (kklic at redhat.com)
- Show error message when abrtd service is run as non-root. rhbz#584352 (kklic at redhat.com)
- Rename EnableOpenGPG to OpenGPGCheck in the man page rhbz#584332 (kklic at redhat.com)
- Document ProcessUnpackaged in abrt.conf.5. Document default values. (kklic at redhat.com)
- Crash function is now detected even for threads without an abort frame (kklic at redhat.com)
- comment can be private (npajkovs at redhat.com)
- do not catch perl/python crashes when the script is not of known package origin (kklic at redhat.com)
- kerneloop is more informative when failed (npajkovs at redhat.com)
- add function name into summary(if it's found) (npajkovs at redhat.com)
- Change kerneloops message when it fails (npajkovs at redhat.com)
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #564451 - ABRT makes my computer unusable
        https://bugzilla.redhat.com/show_bug.cgi?id=564451
  [ 2 ] Bug #582421 - RFE: Exclude crashes in examples scripts from triggering a crash report dialog
        https://bugzilla.redhat.com/show_bug.cgi?id=582421
  [ 3 ] Bug #580899 - abrtd is dead. exits with unclear error message, invalid number ''
        https://bugzilla.redhat.com/show_bug.cgi?id=580899
  [ 4 ] Bug #579748 - obsolete gnome-python2-bugbuddy
        https://bugzilla.redhat.com/show_bug.cgi?id=579748
  [ 5 ] Bug #587698 - new abrt icons for f13
        https://bugzilla.redhat.com/show_bug.cgi?id=587698
--------------------------------------------------------------------------------


================================================================================
 aldrin-0.13-4.fc12 (FEDORA-2010-9243)
 Modular music sequencer/tracker
--------------------------------------------------------------------------------
Update Information:

armstrong changes:  - Fix stack smashing in 32 bit systems          - More lunar
fixes  - Superfm fix  - New lunar note plugin    aldrin changes:  - Change
device order in autodetect. Prevents a possible crash.  - Fix segfault in
waveedit when deleting end of waveform.
--------------------------------------------------------------------------------
ChangeLog:

* Sat Mar  6 2010 Orcan Ogetbil <oget [DOT] fedora [AT] gmail [DOT] com> - 0.13-4
- Change device order in autodetect. Prevents a possible crash.
- Fix segfault in waveedit when deleting end of waveform.
- Comply with new python guidelines
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #508779 - aldrin won't start on fc11
        https://bugzilla.redhat.com/show_bug.cgi?id=508779
--------------------------------------------------------------------------------


================================================================================
 armstrong-0.2.6-11.fc12 (FEDORA-2010-9243)
 Powerful music sequencing library
--------------------------------------------------------------------------------
Update Information:

armstrong changes:  - Fix stack smashing in 32 bit systems          - More lunar
fixes  - Superfm fix  - New lunar note plugin    aldrin changes:  - Change
device order in autodetect. Prevents a possible crash.  - Fix segfault in
waveedit when deleting end of waveform.
--------------------------------------------------------------------------------
ChangeLog:

* Fri Mar  5 2010 Orcan Ogetbil <oget [DOT] fedora [AT] gmail [DOT] com>  0.2.6-11
- Fix stack smashing in 32 bit systems RHBZ#508779
- More lunar fixes
- Superfm fix
- New lunar note plugin
* Sat Feb 13 2010 Orcan Ogetbil <oget [DOT] fedora [AT] gmail [DOT] com>  0.2.6-10
- Link against rtaudio-4.0.7
- Repair lunar support
* Sat Jan 30 2010 Orcan Ogetbil <oget [DOT] fedora [AT] gmail [DOT] com>  0.2.6-9
- Rebuild against portmidi-200 (on F-13+)
- Make the pyzzub package noarch
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #508779 - aldrin won't start on fc11
        https://bugzilla.redhat.com/show_bug.cgi?id=508779
--------------------------------------------------------------------------------


================================================================================
 bdii-5.1.5-1.fc12 (FEDORA-2010-9292)
 The Berkeley Database Information Index (BDII)
--------------------------------------------------------------------------------
Update Information:

The Berkeley Database Information Index (BDII) consists of a standard LDAP
database which is updated by an external process. The update process obtains
LDIF from a number of sources and merges them. It then compares this to the
contents of the database and creates an LDIF file of the differences. This is
then used to update the database.
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #576839 - Review Request: bdii - The Berkeley Database Information Index (BDII)
        https://bugzilla.redhat.com/show_bug.cgi?id=576839
--------------------------------------------------------------------------------


================================================================================
 calibre-0.6.55-1.fc12 (FEDORA-2010-9230)
 E-book converter and library management
--------------------------------------------------------------------------------
Update Information:

An update to the latest upstream release. Hopefully this fixes a number of
crashes that folks have been seeing. Please test this package and update any of
the bugs if you still see crashes.
--------------------------------------------------------------------------------
ChangeLog:

* Fri May 28 2010 Kevin Fenzi <kevin at tummy.com> - 0.6.55-1
- Update to 0.6.55
* Fri May 21 2010 Kevin Fenzi <kevin at tummy.com> - 0.6.54-1
- Update to 0.6.54
* Fri May 21 2010 Kevin Fenzi <kevin at tummy.com> - 0.6.53-1
- Update to 0.6.53
* Wed May  5 2010 Marcela Maslanova <mmaslano at redhat.com> - 0.6.47-2
- Rebuild against new poppler
* Sat Apr 10 2010 Ionuț C. Arțăriși <mapleoin at fedoraproject.org> - 0.6.47-1
- new upstream release 0.6.47
- new chmlib requirement
- create directory for calibre's environment module
- use bzip2 instead of gzip when preparing tarball in generate-tarball.sh
- remove cssutils patches (we now have python-cssutils 0.9.6 in Fedora)
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #549445 - [abrt] crash in calibre-0.6.26-1.fc12
        https://bugzilla.redhat.com/show_bug.cgi?id=549445
  [ 2 ] Bug #551024 - [abrt] crash detected in calibre-0.6.26-1.fc12 (custom pyPdf)
        https://bugzilla.redhat.com/show_bug.cgi?id=551024
  [ 3 ] Bug #559484 - [abrt] crash in calibre-0.6.35-3.fc12
        https://bugzilla.redhat.com/show_bug.cgi?id=559484
  [ 4 ] Bug #559862 - [abrt] crash in calibre-0.6.35-3.fc12
        https://bugzilla.redhat.com/show_bug.cgi?id=559862
  [ 5 ] Bug #562512 - [abrt] crash in calibre-0.6.37-1.fc12 (utf8 codec can't decode...)
        https://bugzilla.redhat.com/show_bug.cgi?id=562512
  [ 6 ] Bug #573353 - [abrt] calibre 0.6.26-1.fc12 - prs-500
        https://bugzilla.redhat.com/show_bug.cgi?id=573353
  [ 7 ] Bug #580310 - [abrt] crash in calibre-0.6.42-1.fc12: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
        https://bugzilla.redhat.com/show_bug.cgi?id=580310
  [ 8 ] Bug #581856 - [abrt] crash in calibre-0.6.42-1.fc12: crop.py:105:crop_pdf:TypeError: __init__() got an unexpected keyword argument 'title'
        https://bugzilla.redhat.com/show_bug.cgi?id=581856
  [ 9 ] Bug #583461 - [abrt] crash in calibre-0.6.42-1.fc12: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
        https://bugzilla.redhat.com/show_bug.cgi?id=583461
  [ 10 ] Bug #584223 - [abrt] crash in calibre-0.6.42-1.fc12: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
        https://bugzilla.redhat.com/show_bug.cgi?id=584223
  [ 11 ] Bug #585329 - [abrt] crash in calibre-0.6.42-1.fc12: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
        https://bugzilla.redhat.com/show_bug.cgi?id=585329
  [ 12 ] Bug #585389 - [abrt] crash in calibre-0.6.42-1.fc12: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
        https://bugzilla.redhat.com/show_bug.cgi?id=585389
  [ 13 ] Bug #586582 - [abrt] crash in calibre-0.6.42-1.fc12: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
        https://bugzilla.redhat.com/show_bug.cgi?id=586582
  [ 14 ] Bug #587706 - [abrt] crash in calibre-0.6.42-1.fc12: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
        https://bugzilla.redhat.com/show_bug.cgi?id=587706
  [ 15 ] Bug #587821 - [abrt] crash in calibre-0.6.42-1.fc12: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
        https://bugzilla.redhat.com/show_bug.cgi?id=587821
  [ 16 ] Bug #594940 - [abrt] crash in calibre-0.6.35-3.fc12
        https://bugzilla.redhat.com/show_bug.cgi?id=594940
--------------------------------------------------------------------------------


================================================================================
 canorus-0.7-6.R1213.20100530svn.fc12 (FEDORA-2010-9311)
 Music Score Editor
--------------------------------------------------------------------------------
Update Information:

Bugfixes in:  - exporting text on chords to Lilypond  - unable to save the
document.  - unsaved changes warning dialog when opening recent documents  -
sheet properties toolbar when removing the last sheet  - properties dialog
layout  - default note stem direction  - score user interface
--------------------------------------------------------------------------------
ChangeLog:

* Sun May 30 2010 Orcan Ogetbil <oget[DOT]fedora[AT]gmail[DOT]com> - 0.7-6.R1213.20100530svn
- Fix DSO linking
* Sun May 30 2010 Orcan Ogetbil <oget[DOT]fedora[AT]gmail[DOT]com> - 0.7-5.R1213.20100530svn
- SVN revision 1213
--------------------------------------------------------------------------------


================================================================================
 cdf-0.2-3.fc12 (FEDORA-2010-9308)
 A colorized df
--------------------------------------------------------------------------------


================================================================================
 emacs-vm-8.1.1-1.fc12 (FEDORA-2010-9251)
 Emacs VM mailreader
--------------------------------------------------------------------------------
Update Information:

Update to new upstream bugfix version with updated support for org-mode, and
POP/IMAP folders
--------------------------------------------------------------------------------
ChangeLog:

* Wed May 26 2010 Jonathan G. Underwood <jonathan.underwood at gmail.com> - 8.1.1-1
- Update to version 8.1.1
- Fix source URL
* Thu Apr  1 2010 Jonathan G. Underwood <jonathan.underwood at gmail.com> - 8.1.0-1
- Update to version 8.1.0 final
- Remove -fno-var-tracking-assignments from CFLAGS once more
* Mon Feb  8 2010 Jonathan G. Underwood <jonathan.underwood at gmail.com> - 8.1.0-0.3.beta2
- Add missing version.txt file to file list
* Mon Feb  8 2010 Jonathan G. Underwood <jonathan.underwood at gmail.com> - 8.1.0-0.2.beta2
- Update to 8.1.0-beta2
--------------------------------------------------------------------------------


================================================================================
 erlang-esasl-0.1-5.fc12 (FEDORA-2010-9286)
 Simple Authentication and Security Layer (SASL) support for Erlang
--------------------------------------------------------------------------------
Update Information:

Narrowed explicit requires.
--------------------------------------------------------------------------------
ChangeLog:

* Fri May 28 2010 Peter Lemenkov <lemenkov at gmail.com> 0.1-5
- Narrow explicit requires
--------------------------------------------------------------------------------


================================================================================
 gpodder-2.3-3.fc12 (FEDORA-2010-9232)
 Podcast receiver/catcher written in Python
--------------------------------------------------------------------------------
Update Information:

* Fix an exception which was raised if the episode list was in an inconsistent
state  * Fix an exception which was raised if Subscriptions -> Podcast settings
was clicked while the All episodes item was selected
--------------------------------------------------------------------------------
ChangeLog:

* Fri May 28 2010 Ville-Pekka Vainio <vpivaini AT cs.helsinki.fi> - 2.3-3
- Forgot to cvs add the other patch, rebuild
* Fri May 28 2010 Ville-Pekka Vainio <vpivaini AT cs.helsinki.fi> - 2.3-2
- Add a patch from upstream for TypeError in gui.py, upstream bug #934,
  rhbz #594907
- Add a patch by Jeff to fix main menu items for "All episodes" view
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #594907 - [abrt] crash in gpodder-2.3-1.fc12: gui.py:2025:play_or_download:TypeError: unknown type (null)
        https://bugzilla.redhat.com/show_bug.cgi?id=594907
--------------------------------------------------------------------------------


================================================================================
 grub2-1.98-2.fc12 (FEDORA-2010-9288)
 Bootloader with support for Linux, Multiboot and more
--------------------------------------------------------------------------------
Update Information:

Update to 1.98 fixes device detection
--------------------------------------------------------------------------------
ChangeLog:

* Fri May 28 2010 Dennis Gilmore <dennis at ausil.us> - 1:1.98-2
- add patch so grub2-probe works with lvm to detect devices correctly
* Wed Apr 21 2010 Dennis Gilmore <dennis at ausil.us> - 1:1.98-1
- update to 1.98
* Fri Feb 12 2010 Dennis Gilmore <dennis at ausil.us> - 1:1.97.2-1
- update to 1.97.2
* Wed Jan 20 2010 Dennis Gilmore <dennis at ausil.us> - 1:1.97.1-5
- drop requires on mkinitrd
* Tue Dec  1 2009 Dennis Gilmore <dennis at ausil.us> - 1:1.97.1-4
- add patch so that grub2 finds fedora's initramfs
--------------------------------------------------------------------------------


================================================================================
 imapsync-1.311-1.fc12 (FEDORA-2010-9242)
 Tool to migrate email between IMAP servers
--------------------------------------------------------------------------------
Update Information:

Upgrade to 1.311
--------------------------------------------------------------------------------
ChangeLog:

* Fri May 28 2010 Nick Bebout <nb at fedoraproject.org> - 1.311-1
- Upgrade to 1.311
- License is now WTFPL
--------------------------------------------------------------------------------


================================================================================
 ircd-hybrid-7.2.3-11.fc12 (FEDORA-2010-9312)
 Internet Relay Chat Server
--------------------------------------------------------------------------------
Update Information:

Two vulnerabilities were reported in ircd-hybrid, ircd-ratbox, and oftc-hybrid.
The first is an integer overflow that can lead to a denial of service or,
possibly, the execution of arbitrary code on the ircd server (CVE-2009-4016
(patch [1])), the second is a NULL pointer dereference that can lead to a
denial of service of the ircd server (CVE-2010-0300 (patch [2])).    This has
been corrected in upstream ircd-ratbox 2.2.9 [3].  CVE-2010-0300 may  be ircd-
ratbox specific, however CVE-2009-4016 affects both ircd servers.    [1]
http://ircd.ratbox.org/cgi-bin/index.cgi/ircd-
ratbox/branches/RATBOX_3_0/src/cache.c?r1=26334&r2=26732  [2]
http://trac.oftc.net/projects/oftc-hybrid/changeset/1062  [3]
http://lists.ratbox.org/pipermail/ircd-ratbox/2010-January/000891.html
--------------------------------------------------------------------------------
ChangeLog:

* Sat May 29 2010 Rakesh Pandit <rakesh at fedoraproject.org> - 7.2.3-11
- BZ Bug 559383 - CVE-2009-4016 CVE-2010-0300 ircd-{hybrid,ratbox}: multiple vulnerabilities
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #559382 - CVE-2009-4016 CVE-2010-0300 ircd-{hybrid,ratbox}: multiple vulnerabilities
        https://bugzilla.redhat.com/show_bug.cgi?id=559382
--------------------------------------------------------------------------------


================================================================================
 ircd-ratbox-2.2.8-7.fc12 (FEDORA-2010-9312)
 Ircd-ratbox is an advanced, stable and fast ircd
--------------------------------------------------------------------------------
Update Information:

Two vulnerabilities were reported in ircd-hybrid, ircd-ratbox, and oftc-hybrid.
The first is an integer overflow that can lead to a denial of service or,
possibly, the execution of arbitrary code on the ircd server (CVE-2009-4016
(patch [1])), the second is a NULL pointer dereference that can lead to a
denial of service of the ircd server (CVE-2010-0300 (patch [2])).    This has
been corrected in upstream ircd-ratbox 2.2.9 [3].  CVE-2010-0300 may  be ircd-
ratbox specific, however CVE-2009-4016 affects both ircd servers.    [1]
http://ircd.ratbox.org/cgi-bin/index.cgi/ircd-
ratbox/branches/RATBOX_3_0/src/cache.c?r1=26334&r2=26732  [2]
http://trac.oftc.net/projects/oftc-hybrid/changeset/1062  [3]
http://lists.ratbox.org/pipermail/ircd-ratbox/2010-January/000891.html
--------------------------------------------------------------------------------
ChangeLog:

* Sat May 29 2010 Rakesh Pandit <rakesh at fedoraproject.org> - 2.2.9-7
- BZ Bug 559383 - CVE-2009-4016 CVE-2010-0300 ircd-{hybrid,ratbox}: multiple vulnerabilities
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #559382 - CVE-2009-4016 CVE-2010-0300 ircd-{hybrid,ratbox}: multiple vulnerabilities
        https://bugzilla.redhat.com/show_bug.cgi?id=559382
--------------------------------------------------------------------------------


================================================================================
 isdn4k-utils-3.2-71.fc12 (FEDORA-2010-9244)
 Utilities for configuring an ISDN subsystem
--------------------------------------------------------------------------------
Update Information:

- enable capi.new  - fix multilib issue
--------------------------------------------------------------------------------
ChangeLog:

* Fri May 14 2010 Than Ngo <than at redhat.com> - 3.2-71
- fix bz#566909, thanks to Louis Lagendijk
    - own LIBDIR/capi
    - fix loading of plugins
    - remove chkconfig capi off
* Tue May  4 2010 Than Ngo <than at redhat.com> - 3.2-70
- enable capi.new
- add 40-isdn.rules, it's dropped from udev in F14 and later
- fix multilib issue
- add subpackage doc
* Mon May  3 2010 Than Ngo <than at redhat.com> - 3.2-69
- fix quotation issue with autoconf-2.64
- fix bz#556056, split off -static subpackage
- fix bz#539020, FTBFS
* Fri Jan 15 2010 Than Ngo <than at redhat.com> - 3.2-68
- fix license
- cleanup
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #566909 - RFE: please change isdn4k-utils to use capi20.new
        https://bugzilla.redhat.com/show_bug.cgi?id=566909
--------------------------------------------------------------------------------


================================================================================
 jaxodraw-2.0.1-5.fc12 (FEDORA-2010-9303)
 A Java program for drawing Feynman diagrams
--------------------------------------------------------------------------------
Update Information:

Added man page and desktop icon.
--------------------------------------------------------------------------------
ChangeLog:

* Sat May 29 2010 Jussi Lehtola <jussilehtola at fedoraproject.org> - 2.0.1-5
- Added man page and desktop icon.
--------------------------------------------------------------------------------


================================================================================
 kicad-2010.05.27-2.rev2363.fc12 (FEDORA-2010-9287)
 Electronic schematic diagrams and printed circuit board artwork
--------------------------------------------------------------------------------
ChangeLog:

* Sat May 29 2010 Alain Portal <alain.portal[AT]univ-montp2[DOT]fr> 2010.05.27-2
- Don't forget icons
* Sat May 29 2010 Alain Portal <alain.portal[AT]univ-montp2[DOT]fr> 2010.05.27-1
- New packager version
- Update kicad version number patch
- Patch to fix https://bugs.launchpad.net/kicad/+bug/587175
- Patch to fix https://bugs.launchpad.net/kicad/+bug/587176
* Fri May 21 2010 Alain Portal <alain.portal[AT]univ-montp2[DOT]fr> 2010.05.09-3
- Fix the kicad version number
- Fix a problem when trying to modify a footprint value in eeschema
  https://bugs.launchpad.net/kicad/+bug/583939
* Tue May 18 2010 Alain Portal <alain.portal[AT]univ-montp2[DOT]fr> 2010.05.09-2
- No backup of patched files to deleted
- Add noreplace flag to config macro
* Mon May 17 2010 Alain Portal <alain.portal[AT]univ-montp2[DOT]fr> 2010.05.09-1
- New upstream version
- All previous patches no more needed
- Backward to cmake 2.6 requirement
* Sun May  9 2010 Alain Portal <alain.portal[AT]univ-montp2[DOT]fr> 2010.05.05-1
- New upstream version
- All previous patches no more needed
- Fix url: KiCad move from SourceForge.net to LaunchPad.net
- Remove vendor tag from desktop-file-install
- Add x-kicad-pcbnew mimetype
- Add new icons for mimetype
* Mon May  3 2010 Alain Portal <alain.portal[AT]univ-montp2[DOT]fr> 2010.04.06-9.rev2515
- Fix a minor bug that occurs when changing module orientation or side
* Mon May  3 2010 Alain Portal <alain.portal[AT]univ-montp2[DOT]fr> 2010.04.06-8.rev2515
- Auto update 3D viewer: fix https://bugs.launchpad.net/kicad/+bug/571089
- Create png from screen (libedit): fix https://bugs.launchpad.net/kicad/+bug/573833
* Sun May  2 2010 Alain Portal <alain.portal[AT]univ-montp2[DOT]fr> 2010.04.06-7.rev2515
- Rename COTATION class (french word) in DIMENSION and fix
  https://bugs.launchpad.net/kicad/+bug/568356 and https://bugs.launchpad.net/kicad/+bug/568357
- Some code cleaning ans enhancements + fix a bug about last netlist file used (LP #567902)
* Sat May  1 2010 Alain Portal <alain.portal[AT]univ-montp2[DOT]fr> 2010.04.06-6.rev2515
- Make cleanup feature undoable, fix https://bugs.launchpad.net/kicad/+bug/564619
- Fix issues in SVG export, fix https://bugs.launchpad.net/kicad/+bug/565388
- Minor pcbnew enhancements
- Fix minor gerber problems, fix https://bugs.launchpad.net/kicad/+bug/567881
* Sat May  1 2010 Alain Portal <alain.portal[AT]univ-montp2[DOT]fr> 2010.04.06-5.rev2515
- DRC have to use the local parameters clearance if specified,
  and NETCLASS value only if no local value specified.
* Sat May  1 2010 Alain Portal <alain.portal[AT]univ-montp2[DOT]fr> 2010.04.06-4.rev2514
- Fix https://bugs.launchpad.net/bugs/568896 and https://bugs.launchpad.net/bugs/569312
* Thu Apr 29 2010 Alain Portal <alain.portal[AT]univ-montp2[DOT]fr> 2010.04.06-3.rev2514
- Fix a crash that happens sometimes when opening the design rule dialog
* Mon Apr 26 2010 Alain Portal <alain.portal[AT]univ-montp2[DOT]fr> 2010.04.06-2.rev2514
- Fix https://bugs.launchpad.net/bugs/570074
* Mon Apr 12 2010 Alain Portal <alain.portal[AT]univ-montp2[DOT]fr> 2010.04.06-1.rev2514
- New upstream version
- Patches no more needed
* Mon Apr  5 2010 Alain Portal <alain.portal[AT]univ-montp2[DOT]fr> 2010.03.14-5.rev2463
- Add patch to fix SF #2981759
* Sat Apr  3 2010 Alain Portal <alain.portal[AT]univ-montp2[DOT]fr> 2010.03.14-4.rev2463
- Apply upstream patch to fix inch/mm ratio
- Provide a source download URL
--------------------------------------------------------------------------------


================================================================================
 kpartsplugin-0.0.1-0.2.20100521.fc12 (FEDORA-2010-9222)
 KParts technology to embed file viewers into non-KDE browsers
--------------------------------------------------------------------------------
Update Information:

This software implements a plug-in for Netscape-compatible browsers in a Unix
environment. This plug-in uses KDE's KParts technology to embed file viewers
(e.g. for PDF files) into non-KDE browsers. Tested browsers include both
Mozilla Firefox and Opera.  With this plug-in, you can e.g. view PDF files in
Firefox using Okular as an   embedded plug-in.
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #594839 - Review Request: kpartsplugin -  KParts technology to embed file viewers into non-KDE browsers
        https://bugzilla.redhat.com/show_bug.cgi?id=594839
--------------------------------------------------------------------------------


================================================================================
 mozilla-noscript-1.9.9.81-1.fc12 (FEDORA-2010-9266)
 JavaScript white list extension for Mozilla Firefox
--------------------------------------------------------------------------------
Update Information:

[+] new feature, [x] bug fix, [-] removed feature, [=] repackaging or cosmetic
change    v 1.9.9.81
==========================================================================  +
Experimental blocking of page refreshes happening inside untrusted    unfocused
tabs, should provide protection against Aviv Raff's scriptless    "tabnabbing"
variant. Enabled by default, can be controlled through the
noscript.forbidBGRefresh about:config integer preference:    0 - no blocking
1 - block refreshes on untrusted unfocused tabs    2 - block refreshes on
trusted unfocused tabs    3 - block refreshes on both trusted and untrusted
unfocused tab    Address patterns matching pages which shouldn't be affected can
be    listed in the noscript.forbidBGRefresh.exceptions preference  x Fixed XSS
false positive in new 3.7 add-ons manager  x Fixed meta-refresh URL parsing
mismatch  x Fixed import script surrogates being broken by a 1.9.9.79 regression
v 1.9.9.80
==========================================================================  x
Fixed "Partially allowed scripts" icon shown instead of the "Scripts    allowed
but some objects blocked" one when the blocked objects' domains    are not
whitelisted for scripting (thanks al_9x for reporting)  x Fixed "Scripts allowed
but some objects blocked" icon not being used for    blocked web fonts (thanks
Alan Baxter for reporting)  x (ABE) Deny on INCLUSION don't trigger a
notification even if the blocked    request is for a subdocument (the blocking
is logged in the Console, use    SUB if user-facing notification is needed)  x
Fixed privileged XMLHttpRequests for untrusted resources being blocked    if
HTTP redirections occurred (thanks mari for reporting)  + Better compatibility
with IronPort web-based tools (thanks Ron Collins    for reporting)    v
1.9.9.79
==========================================================================  x
Script surrogates whose source starts with the '!' get executed on    pages
where scripts are disabled (on document DOM completion, rather    than before
HTML parsing starts like regular surrogates)    v 1.9.9.78
==========================================================================  x
Redirect cache for scripts and XBL only  x Fixed cross-site CSS being blocked
under some circumstances (e.g.    on Flicker and Yahoo)    v 1.9.9.77
==========================================================================  +
ABE INCLUSION(type1, type2, type3...) pseudo-method allows rules to take
request type (e.g. SCRIPT vs CSS) in account  + ABE SELF+ (same domain) and
SELF++ (same base domain) pseudo-origins  x Fixed iconic feedback
inconsistencies when untrusted blocked objects    are mixed with full-trusted
content (tanks al_9x for reporting)  x Fixed Injection Checker false positives
on some kinds of complex nested    URLs (thanks Sirdarckcat for reporting)  x
Tweaked ClearClick for Disqus compatibility (thanks John for reporting)    v
1.9.9.76
==========================================================================  x
Fixed broken menu on Minefield when External Filters are enabled (thanks
linuser for reporting)  x Fixed about: URL not being shown in NoScript menu
(thanks al_9x for    reporting)  x Removed minor strict warnings on Minefield
v 1.9.9.75
==========================================================================  x
Redirected site caching now skips plugin content  x Removed __parent__ usages
for Minefield compatibility  x Removed some strict warnings (thanks timeless for
reporting)
--------------------------------------------------------------------------------
ChangeLog:

* Fri May 28 2010 Thomas Spura <tomspur at fedoraproject.org> - 1.9.9.81-1
- new version
* Mon May 24 2010 Thomas Spura <tomspur at fedoraproject.org> - 1.9.9.79-1
- new version
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #593247 - mozilla-noscript-1.9.9.81 is available
        https://bugzilla.redhat.com/show_bug.cgi?id=593247
--------------------------------------------------------------------------------


================================================================================
 papyrus-0.13.3-1.fc12 (FEDORA-2010-9262)
 Cairo based C++ scenegraph library
--------------------------------------------------------------------------------
Update Information:

This release introduces a new controller named Flasher that derives from
Animator. On each animation frame, Flasher will alternate between showing and
hiding the associated drawables,... causing them to flash at the interval rate
of the animator.    The addition of the Flasher animator exposed a bug that has
been fixed in Drawable's renderer related to the visibility of objects. The
show()/hide() methods should now work as expected.
--------------------------------------------------------------------------------
ChangeLog:

* Thu May 27 2010 Rick L Vinyard Jr <rvinyard at cs.nmsu.edu> - 0.13.3-1
- New release
* Fri Apr 16 2010 Rick L Vinyard Jr <rvinyard at cs.nmsu.edu> - 0.13.2-1
- New release
--------------------------------------------------------------------------------


================================================================================
 perlbrew-0.06-2.fc12 (FEDORA-2010-9277)
 Manage perl installations in your $HOME
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #591812 - Review Request: perlbrew - Manage perl installations in your $HOME
        https://bugzilla.redhat.com/show_bug.cgi?id=591812
--------------------------------------------------------------------------------


================================================================================
 pidgin-2.7.1-1.fc12 (FEDORA-2010-9321)
 A Gtk+ based multiprotocol instant messaging client
--------------------------------------------------------------------------------
Update Information:

New release 2.7.1  - Adds Direct Connection support for MSN  - Numerous bug
fixes    Full Upstream ChangeLog:  - http://developer.pidgin.im/wiki/ChangeLog
Fedora packaging changes:  - Evolution support moved to pidgin-evolution for
F13+
--------------------------------------------------------------------------------
ChangeLog:

* Sun May 30 2010 Stu Tomlinson <stu at nosnilmot.com> 2.7.1-1
- 2.7.1
- Adds Direct Connection support for MSN
- Numerous bug fixes
- Evolution support moved to pidgin-evolution for F13+ (#581144)
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #581144 - REF: Make a separate package for evolution plugin
        https://bugzilla.redhat.com/show_bug.cgi?id=581144
--------------------------------------------------------------------------------


================================================================================
 rhythmbox-equalizer-1.4-1.fc12 (FEDORA-2010-9252)
 An Equalizer plugin for Rhythmbox
--------------------------------------------------------------------------------
Update Information:

Please test if presets are saved and restored correctly, and that they are
remembered
--------------------------------------------------------------------------------
ChangeLog:

* Sun May 30 2010 Hicham HAOUARI <hicham.haouari at gmail.com> 1.4-1
- New upstream release
- Drop the presets per user patch ( gstreamer presets are now used instead )
--------------------------------------------------------------------------------


================================================================================
 rkward-0.5.3-1.fc12 (FEDORA-2010-9299)
 Graphical frontend for R language
--------------------------------------------------------------------------------
Update Information:

    *  New features and improvements     - File browser window saves settings on
exit - Plugin dialogs are shown with a larger initial size - Add close buttons
to each tab in the main document view area (not available in KDE 4.0) - Make
"print", "export as HTML", "dynamic word wrap", and "increase/descress font
size" available for the console window - Use a native menu, instead of the
default TclTk-menu - Added "paste special" action to script editor and console
for pasting R vectors and matrices from spreadsheets - File->Open R Script File
now allows to specify the character encoding to use - Initialize the output file
with an appropriate encoding specification - Add SVG support to export
(graphics) plugin - Add basic settings format settings for graphics output -
Convert all plugins to use ECMAscript instead of PHP; RKWard no longer depends
on PHP        * Fixes and corrections     - Fixed: Windows->Activate->Window
left / right actions were always disabled - Several windows-specific bugs were
fixed - Fixed: Newly created variables were not properly updated when closing
and re-opening the editor - Fix order of menus for detached windows - Fixed: No
entries were added the recent script/workspaces actions after "save as" - Fixed:
Frequent crashes while running automated plugintests - Fixed: Filenames without
extension would not be shown in file dialogs - Fixed: Calling "fix(my.fun)"
would remove comments - Fixed: Removing "@CRAN@" from the repositories would
break package installation
--------------------------------------------------------------------------------
ChangeLog:

* Mon May 31 2010 pingou <pingou at pingoured.fr> - 0.5.3-1
- Update to 0.5.3
* Wed Nov 25 2009 Kevin Kofler <Kevin at tigcc.ticalc.org> - 0.5.2-2
- Rebuild for Qt 4.6.0 RC1 in F13 (was built against Beta 1 with unstable ABI)
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #597972 - Need recompilation of rkward with R 2.10
        https://bugzilla.redhat.com/show_bug.cgi?id=597972
--------------------------------------------------------------------------------


================================================================================
 roundup-1.4.13-2.fc12 (FEDORA-2010-9279)
 Simple and flexible issue-tracking system
--------------------------------------------------------------------------------
Update Information:

Updated to 1.4.13
--------------------------------------------------------------------------------
ChangeLog:

* Sat May 29 2010 John Khvatov <ivaxer at fedoraproject.org> - 1.4.13-2
- updated to 1.4.13
--------------------------------------------------------------------------------


================================================================================
 squid-3.1.4-1.fc12 (FEDORA-2010-9272)
 The Squid proxy caching server
--------------------------------------------------------------------------------
Update Information:

Upstream 3.1.4 bugfix release, issues relating to IPv6, TPROXY, Memory
management, follow_x_forwarded_for, and stability fixes
--------------------------------------------------------------------------------
ChangeLog:

* Sun May 30 2010 Henrik Nordstrom <henrik at henriknordstrom.net> - 7:3.1.4-1
- Upstream 3.1.4 bugfix release, issues relating to IPv6, TPROXY, Memory
  management, follow_x_forwarded_for, and stability fixes
* Fri May 14 2010 Henrik Nordstrom <henrik at henriknordstrom.net> - 7:3.1.3-2
- Fully fix #548903 - "comm_open: socket failure: (97) Address family not supported by protocol" if IPv6 disabled
- Various IPv6 related issues fixed, making tcp_outgoing_address behave
  as expected and no commResetFD warnings when using tproxy setups.
* Sun May  2 2010 Henrik Nordstrom <henrik at henriknordstrom.net> - 7:3.1.3-1
- Update to 3.1.3 Upstream bugfix release, fixing WCCPv1
* Mon Apr 19 2010 Henrik Nordstrom <henrik at henriknordstrom.net> - 7:3.1.1-3
- Bug #583489: Adjust logrotate script to changes in logrotate package.
* Fri Apr  2 2010 Jiri Skala <jskala at redhat.com> - 7:3.1.1-2
- fixes #548903 - "comm_open: socket failure: (97) Address family not supported by protocol" if IPv6 disabled
--------------------------------------------------------------------------------


================================================================================
 surfraw-2.2.7-1.fc12 (FEDORA-2010-9227)
 Shell Users Revolutionary Front Rage Against the Web
--------------------------------------------------------------------------------
Update Information:

Update to version 2.2.7. Changes include new elvi bing, bookfinder, bugmenot,
duckduckgo, scroogle and amendo, as well as fixes and enhancements for other
elvi.
--------------------------------------------------------------------------------
ChangeLog:

* Sun May 30 2010 Thomas Moschny <thomas.moschny at gmx.de> - 2.2.7-1
- Update to 2.2.7.
--------------------------------------------------------------------------------


================================================================================
 tinyproxy-1.8.1-1.fc12 (FEDORA-2010-9218)
 A small, efficient HTTP/SSL proxy daemon
--------------------------------------------------------------------------------
ChangeLog:

* Tue Apr  6 2010 Jeremy Hinegardner <jeremy at hinegardner dot org> - 1.8.1-1
- update to updstream 1.8.1
* Wed Feb 17 2010 Jeremy Hinegardner <jeremy at hinegardner dot org> - 1.8.0-1
- update to upstream 1.8.0
- add logrotate configuration
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #503465 - tinyproxy does not support upstream proxy authentication
        https://bugzilla.redhat.com/show_bug.cgi?id=503465
  [ 2 ] Bug #536785 - tinyproxy package points at wrong URL
        https://bugzilla.redhat.com/show_bug.cgi?id=536785
--------------------------------------------------------------------------------


================================================================================
 uzbl-0-0.13.20100410gitec473e124.fc12 (FEDORA-2010-9234)
 Lightweight WebKit browser following the UNIX philosophy
--------------------------------------------------------------------------------
Update Information:

Split out core and browser subpackages; Enumerate dependencies of the default
scripts (#597238); Minor reorganization; New upstream snapshot
--------------------------------------------------------------------------------
ChangeLog:

* Mon May 31 2010 Daiki Ueno <dueno at redhat.com> - 0-0.13.20100410gitec473e124
- new upstream snapshot.
* Wed Apr 14 2010 Ben Boeckel <MathStuf at gmail.com> - 0-0.12.20100405gitae15d257a
- Split out core and browser subpackages
- Enumerate dependencies of the default scripts
- Minor reorganization
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #597238 - Missing dependency wget in uzbl rpm
        https://bugzilla.redhat.com/show_bug.cgi?id=597238
--------------------------------------------------------------------------------


================================================================================
 waf-1.5.17-1.fc12 (FEDORA-2010-9239)
 A Python-based build system
--------------------------------------------------------------------------------
Update Information:

Update to waf 1.5.17, with a bunch of bug fixes and enhancements, for example:
* Better handling for deleted build folders and files   * New method for
creating empty folders   * Better interaction between swig and qt4, bison and
flex   * Latex/bibtex processing improvements   * d library detection (phobos 1,
2 or tango)    and more. See
http://code.google.com/p/waf/source/browse/tags/waf-1.5.17/ChangeLog for the
full list of changes.
--------------------------------------------------------------------------------
ChangeLog:

* Mon May 24 2010 Thomas Moschny <thomas.moschny at gmx.de> - 1.5.17-1
- Update to 1.5.17.
- Add patch from issue 682 to install 3rd party tools.
--------------------------------------------------------------------------------


================================================================================
 wordpress-plugin-bad-behavior-2.0.36-1.fc12 (FEDORA-2010-9236)
 Bad Behavior plugin for WordPress
--------------------------------------------------------------------------------
Update Information:

Upgrade to 2.0.36
--------------------------------------------------------------------------------
ChangeLog:

* Fri May 28 2010 Nick Bebout <nb at fedoraproject.org> 2.0.36-1
- Update to 2.0.36
--------------------------------------------------------------------------------


================================================================================
 wxPython-2.8.11.0-1.fc12 (FEDORA-2010-9229)
 GUI toolkit for the Python programming language
--------------------------------------------------------------------------------
Update Information:

update to 2.8.11.0 to match the wxGTK version
--------------------------------------------------------------------------------
ChangeLog:

* Mon May 31 2010 Dan Horák <dan[at]danny.cz> - 2.8.11.0-1
- update to 2.8.11.0 (#593837, #595936, #597639)
* Sun May  2 2010 Dan Horák <dan[at]danny.cz> - 2.8.10.1-3
- rebuilt with wxGTK 2.8.11
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #593837 - cannot import wx; symbol not defined in .so file
        https://bugzilla.redhat.com/show_bug.cgi?id=593837
  [ 2 ] Bug #595936 - wxPython 2.8.11.0 solves wxPython/wxWidgets release number mismatch
        https://bugzilla.redhat.com/show_bug.cgi?id=595936
  [ 3 ] Bug #597639 - [abrt] crash in wxPython-2.8.10.1-3.fc13: wxToolBarBase::UpdateWindowUI: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
        https://bugzilla.redhat.com/show_bug.cgi?id=597639
--------------------------------------------------------------------------------


================================================================================
 xinha-0.96.1-1.fc12 (FEDORA-2010-9260)
 A WYSIWIG HTML editor component in Javascript
--------------------------------------------------------------------------------
Update Information:

Name: CVE-2010-1916  URL: http://cve.mitre.org/cgi-
bin/cvename.cgi?name=CVE-2010-1916  Assigned: 20100511  Reference: MISC:
http://www.php-security.org/2010/05/10/mops-2010-019-serendipity-wysiwyg-editor-
plugin-configuration-injection-vulnerability/index.html  Reference: MISC:
http://www.php-security.org/2010/05/10/mops-2010-020-xinha-wysiwyg-plugin-
configuration-injection-vulnerability/index.html    The dynamic configuration
feature in Xinha WYSIWYG editor 0.96 Beta 2  and earlier, as used in Serendipity
1.5.2 and earlier, allows remote  attackers to bypass intended access
restrictions and modify the  configuration of arbitrary plugins via (1) crafted
backend_config_secret_key_location and backend_config_hash parameters  that are
used in a SHA1 hash of a shared secret that can be known or  externally
influenced, which are not properly handled by the  "Deprecated config passing"
feature; or (2) crafted backend_data and  backend_data[key_location] variables,
which are not properly handled  by the xinha_read_passed_data function.  NOTE:
this can be leveraged to  upload and possibly execute arbitrary files via
config.inc.php in the  ImageManager plugin.
--------------------------------------------------------------------------------
ChangeLog:

* Sat May 29 2010 Rakesh Pandit <rakesh at fedoraproject.org> - 0.96.1-1
- Updated to 0.96.1
- CVE-2010-1916 xinha: access restriction bypass [MOPS 2010-020]
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #591701 - CVE-2010-1916 xinha: access restriction bypass [MOPS 2010-020]
        https://bugzilla.redhat.com/show_bug.cgi?id=591701
--------------------------------------------------------------------------------



More information about the test mailing list