Audio and Gallium3D woes in Rawhide

Adam Williamson awilliam at redhat.com
Tue Nov 9 20:18:42 UTC 2010


On Mon, 2010-11-08 at 20:40 -0800, Adam Williamson wrote:
> On Mon, 2010-11-08 at 23:21 -0500, Thomas Belvin wrote:
> > I recently upgraded to Rawhide from F14 Updates-Testing. I can get
> > audio with the old kernel, but booting into the Rawhide kernel kills
> > the audio, and Gallium3D died after the upgrade. I can get pulse audio
> > listed in SystemSettings when I do "pulseaudio -k", but I still get
> > "Dummy Output" every where else and no audio. Also instead of
> > Gallium3D I get software mode in either kernel after the upgrade. I
> > was wondering if no audio and no Gallium3D is common right now in
> > Rawhide. I did a quick search for bugs, but didn't see any for "dummy
> > output" (just a lot of possibly unrelated pulse complaints) or
> > "gallium" (also a lot of possibly unrelated nouveau complaints).
> 
> I just upgraded to Rawhide today and have similar problems. pavucontrol
> reports no available output devices, and though glxinfo reports
> nouveau / gallium3d as the renderer, trying to run gnome-shell I get an
> X error and trying to run compiz I get a bunch of LLVM errors. airlied
> said that will likely get looked at soon. I'm not sure what's going on
> with the Pulse issue.

I looked into the Pulse thing a bit more. The problem appears to be that
the udev-detect module doesn't manage to detect any cards. I've taken a
quick look upstream and the only change that looks possibly relevant is
http://git.0pointer.de/?p=pulseaudio.git;a=commitdiff_plain;h=1552abf62820e063e933e54372bec25f8ea2f68a ; I'm building a PA with that patch included now locally for testing. If it works I'll let you know. If not I'll poke Lennart.
-- 
Adam Williamson
Fedora QA Community Monkey
IRC: adamw | Fedora Talk: adamwill AT fedoraproject DOT org
http://www.happyassassin.net



More information about the test mailing list