F16 Alpha ATI Radeon issues?

Adam Williamson awilliam at redhat.com
Wed Aug 10 17:12:36 UTC 2011


On Wed, 2011-08-10 at 13:00 +0200, Michael Schwendt wrote:
> In an F16 Alpha install done via an upgrade from F15 final, I get various
> rendering issues in GNOME Shell, such as
> 
>   http://mschwendt.fedorapeople.org/tmp/screenshot-f16-alpha-damage1.png
> 
> Not always, but at random times. Also:
>  - perceived lag (compared with F15)
>  - areas of the screen not getting refreshed in time, staying blank
>    until I touch the window or move a GTK slider,
>    e.g. individual mailbox subject lines in Claws Mail summary view
>  - once, a few large black rectangular areas have appeared around an
>    xterm window when moving it above a pair of Emacs and Firefox
>  - lines of output in gnome-terminal and/or xterm don't appear and
>    are displayed only when moving the window or hitting Enter once more
> 
> Is anyone aware of such issues? Is it likely to be a driver issue or
> specific to the GNOME Shell? (dunno whether trying out a different WM would
> be a sufficient test)

I'm seeing similar stuff with nouveau; it seems mostly to be some kind
of buffering issue, window content is not being updated when it should,
and I wind up with old content still there, or apparently blank areas.
Ben was of the opinion it may well be in the Shell stack somewhere
(probably clutter, if I had to guess). I'm meant to test with LXDE or
KDE or something to see if that 'fixes' it, but haven't got around to it
yet.

I haven't seen the out-and-out corruption in your first screenshot,
though, so I think that's something different.

> http://bugz.fedoraproject.org/xorg-x11-drv-ati
> lists 177 tickets. Where can I find a guide on how to report
> "the right stuff"?

-- 
Adam Williamson
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net



More information about the test mailing list