F16 alpha rc4 hangs at grub boot - BZ# 730124

Jurgen Kramer gtmkramer at xs4all.nl
Wed Aug 17 07:45:16 UTC 2011

On Tue, 2011-08-16 at 15:14 -0400, Clyde E. Kunkel wrote:
> On 08/16/2011 01:16 PM, Jurgen Kramer wrote:
> > I've just tried F16 alpha rc4. Installation went without a hitch but
> > unfortunately the system still hangs when grub tries to boot. BZ#
> > 730124.
> >
> > Any pointer how to get past this would be appreciated.
> >
> > Jurgen
> >
> If you have another installation you can boot then create a grub entry 
> in that grub.conf for the F16 distro, boot that and then, as root:
> grub2-install --force /dev/<your /boot partition device>
> If you don't have another bootable distro, boot the DVD and use rescue 
> mode and the chroot option and then do the grub2-install
Thanks for the suggestion. I just tried it with RC5 (which still hangs
at grub). I get:

grub2-install --force /dev/sda3
warn: Attempting to install GRUB to a partitionless disk or a partition.
This is a BAD idea..
warn: Embedding not possible. GRUB can only be installed in this setup
using blocklists. However, blocklists are UNRELIABLE and their use is
Installation finished. No error reported.

This leaves me with a nice penguin with hdd logo at the refit bootloader
(after restoring that). Selecting that gets me to the grub prompt..


More information about the test mailing list