persistent gnome dep problems (F16 alpha rc3-5, alpha), --skip-broken wants to haul in 32-bit libs

Adam Williamson awilliam at redhat.com
Wed Aug 24 18:59:36 UTC 2011


On Wed, 2011-08-24 at 11:08 -0400, Matthias Clasen wrote:
> On Wed, 2011-08-24 at 11:35 +0200, Jurgen Kramer wrote:
> > I have not seen any mention of this on the list so far so here it goes.
> > I've been seeing gnome dep problems for the last few days (through alpha
> > rc's and now alpha).
> 
> > Error: Protected multilib versions:
> > gnome-panel-libs-3.1.5-2.fc16.x86_64 !=
> > gnome-panel-libs-3.0.2-3.fc16.i686
> > 
> 
> I have no idea what these errors mean or how to fix them.
> Any advice would be appreciated. Actually, this one is kind of
> understandable, but I have also seen 'protected multilib' stuff where
> both sides of the != were the same arch, which left me wondering.

This particular one is just an odd artefact of --skip-broken trying to
workaround the dep problems from the *non* --skip-broken run. It
sometimes does some fairly odd things to try and work around the dep
issues. Usually it's not worth worrying about the oddness, in this case,
just focus on resolving the problems noted in the non --skip-broken run.
(Which just look like the Evo update didn't hit the reporter's mirror
yet).
-- 
Adam Williamson
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net



More information about the test mailing list