persistent gnome dep problems (F16 alpha rc3-5, alpha), --skip-broken wants to haul in 32-bit libs

Jonathan Corbet corbet-ft at lwn.net
Thu Aug 25 17:12:24 UTC 2011


On Wed, 24 Aug 2011 11:08:52 -0400
Matthias Clasen <mclasen at redhat.com> wrote:

> > Error: Protected multilib versions:
> > gnome-panel-libs-3.1.5-2.fc16.x86_64 !=
> > gnome-panel-libs-3.0.2-3.fc16.i686
> >   
> 
> I have no idea what these errors mean or how to fix them.
> Any advice would be appreciated. Actually, this one is kind of
> understandable, but I have also seen 'protected multilib' stuff where
> both sides of the != were the same arch, which left me wondering.

I've worked my way through this kind of mess a couple of times now, most
recently yesterday.  Here's my experience:

 - Do a big rawhide update - in this case, at least two weeks worth.

 - Somewhere in the middle, while I'm not looking, the update kills the
   running session and/or X server - I come back to a login screen.  It
   used to be safe to run "yum update" from a terminal window, but,
   seemingly, not anymore.  Not really a step in the right direction. 

 - If I try to rerun the update, it will tell me to try
   yum-complete-transaction.  Each time, actually trying that leads to an
   infinite loop printing dependency information.

 - If I just run "yum update", I get the "protected multilib versions"
   message.

What I have found in these cases is that there are *two* versions of the
indicated library installed simultaneously (for the same architecture).
In each case, simply removing the older version clears the problem.  Once
I've gotten past the gripes, the update actually works.

Dunno if that helps anybody...  never a dull moment...

jon


More information about the test mailing list