persistent gnome dep problems (F16 alpha rc3-5, alpha), --skip-broken wants to haul in 32-bit libs

Adam Williamson awilliam at redhat.com
Thu Aug 25 22:15:12 UTC 2011


On Thu, 2011-08-25 at 14:55 -0400, seth vidal wrote:
> On Thu, 2011-08-25 at 14:28 -0400, Dave Jones wrote:
> > On Thu, Aug 25, 2011 at 02:20:12PM -0400, seth vidal wrote:
> >  
> >  > > Dunno if that helps anybody...  never a dull moment...
> >  > 
> >  > When upgrading rawhide from X - use screen.
> > 
> > and also when upgrading from ssh.
> > 
> > things have definitely gotten a lot more fragile over the last
> > release or two.
> 
> you can disable the multilib protection with:
> 
> yum --setopt="protected_multilib=0" blah blah blah
> 
> which might help in situations where things are already deeply sideways.

worth noting for the record that, as always when using 'force' type
parameters to a package management system, when it breaks - as it
inevitably will - you get a full refund of what you paid for it, and you
get to keep both pieces. =) generally, when yum wants to do something
really funky, the solution is not 'figure out how to let yum do it' but
'figure out why yum wants to do something funky, and fix that'.

(this is obviously not aimed at seth, who knows it already, but at the
thread in general.)
-- 
Adam Williamson
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net



More information about the test mailing list