setting up ssh

Michael Cronenworth mike at
Fri Aug 26 19:04:19 UTC 2011

Peter G. wrote:
> You know, I just tried your command again, but this time without grepping, and
> I see that ssh is nowhere in the output, so how could grep ssh ever return
> anything?

My command was an example of when a firewall rule existed to allow ssh 

> But, when I examine /etc/sysconfig/iptables, I see:
> -A INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT
> Doesn't that mean that port 22 is open?

That is the saved configuration. Running "iptables -L" shows you the 
current, in-memory configuration.

> And if so, why does your command not show any output, while
> /etc/sysconfig/iptables would suggest that the port is opened?

See above.

> Any yet, there is still no communication possible. What is wrong?

Your firewall rule is not active. You can manually add the rule by running:

# iptables -A INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT

As Michael said, system-config-firewall has a bug. You two should file a 
bug against it.

More information about the test mailing list