Yum distro-sync makes more problems than solves

Adam Pribyl pribyl at lowlevel.cz
Fri Feb 11 22:33:38 UTC 2011

On Fri, 11 Feb 2011, Kevin Fenzi wrote:

> On Fri, 11 Feb 2011 22:45:56 +0100 (CET)
> Adam Pribyl <pribyl at lowlevel.cz> wrote:
>> Last example:
>> F12 -> F13
>> there was 126MB of not updated packages in 82 packages.
>> Let's go per instructions
>> 1. yum clean all - no problems
>> 2. rpm --import https://fedoraproject.org/static/97A1071F.txt
>>   - no problems
> Thats the Fedora 14 key. ;)

Right, then this step probably should remain only in F13->F14 not in 
common steps.

>> 3. yum update yum - fetches all repo data again, upgrades yum to
>> latest fc12.
>> 4. yum --releasever=13 distro-sync --skip-broken - updates 81
>> packages from F12 that left for update and finishes.
> I think we should change that probibly to avoid --skip-broken there.
> Instead you should not use --skip-broken and should look at removing
> packages that can't be updated. (ie, orphans in the new release).

I absolutely agree here, as one of such updates ended up for me with half 
packages updated, while the rest un-updated, resulting in malfunctioning 
system due to one unsolvable dependency problem, which I finaly solved by 
removig some problematic package. The dependency problems should be solved 
by hand before "mass update" as --skip-broken is not a solution.

>> 5. yum repolist - shows all repos are still set to fc12.
>> 6. now improvisation starts:
>>   yum --releasever=13 distro-sync --skip-broken - yum can not end
>> dependency resolution, it was still cycling thru dependencies
>> suggesting many packages to erase or downgrade, it does not react to
>> ^C, nor kill -15, have to use kill -9 to end it.
>> 7. yum clean all - no problems
>> 8. yum --releasever=13 distro-sync --skip-broken - finaly does
>> resolves 373MB in 752 packages to update for fc13. However it ends up
>> with message "The GPG keys listed for "Fedora 13 - i386 - Updates"
>> repository already installed, but they are not correct for this
>> package. Check that the correct URLs are configure for this
>> repository." What the heck is this about?
> You need to import the Fedora 13 key above, instead of the 14 one.
> The fedora-release you have installed doesn't match the new keys, so
> you need to import those first.

I did not installed any fedora-release yet. The message says that the key 
is installed, but URL in repo conf files is wrong - that's how I 
understand it.

>> Last time, somebody was interested in checking what's wrong. Here I
>> am. System is not updated and I am waiting and willing to help with
>> YumUpgradeFaq page update to make the steps really working.

Acctualy thanks for your answers, but I am not seeking for help, as I am 
able to well help myself, but I'd like to clarify the YumUpgrade page 
steps to be able to improve the page, so the yum upgrades really work, as 
they do not for me most of the times.

IMHO there are three problems:
1. keys needs to be imported per distro version
2. "yum clean all" can not be followed by "yum update yum" but should be 
switched, otherwise yum distro-sync is using incorrect metadata
3. should remove --skip-broken and ask users to solve broken deps before 
distro-sync as skipping brokens is not a solution

> kevin

Adam Pribyl

More information about the test mailing list