Peer cert error during netinstall

Tim Flink tflink at
Mon Feb 21 17:55:35 UTC 2011

On 02/21/2011 10:04 AM, Tim Flink wrote:
> I'm hitting an issue with netinstall and DVD install on F15 i386 (tried
> TC2, 20110220 nightly) that I can't reproduce on a VM. I'm going to try
> another physical machine to verify that it isn't HW specific but I was
> wondering if anyone else has seen it:
> I get through the installer without issue until it tries to grab repo
> information (if updates are enabled for the DVD). At that point, I get
> an error message:
> "
> Unable to read package metadata. This may be due to a missing repodata
> directory. Please ensure that your install tree has been correctly
> generated.
> Cannot retrieve repository metadata (repomd.xml) to repository: fedora.
> Please verify its path and try again.
> "
> When I look through the anaconda logs, I see:
> INFO anaconda: Error downloading treeinfo: [Errno 14] Peer cert cannot
> be verified or peer cert invalid
> I can file a BZ for this but wanted to get a better handle on the cause
> first.
> Tim

This does appear to be at least somewhat HW specific. I tried it on 
another machine of the same vintage (but different NIC and chipset) and 
did not see the same issue.

More information about the test mailing list