Fedora 15 installer help

Dennis Gilmore dennis at ausil.us
Wed Feb 23 05:46:05 UTC 2011

On Tuesday, February 22, 2011 09:51:23 PM Evan Klitzke wrote:
> Hi all,
> I recently got a Mac Mini "server" edition which means it has two HDDs and
> no CD drive. Trying to get Linux installed on this thing has been a bit of
> a challenge, since I can't boot from a CD and EFI support on Macs seems
> unreliable/unsupported -- but I think with the Fedora 15 release I'm
> really close to being able to do it.
> So to boot an installer on this thing, I need an EFI image on a USB disk.
> Tried to create a liveusb CD on Fedora 14, couldn't boot the EFI image.
> What would happen is I'd boot up and get the GRUB screen with the splash
> image, could edit the kernel/initrd lines, etc. but when I try to boot
> nothing happens, the screen just stays stuck on the GRUB splash screen.
> Discovered the efidisk.img files on the Fedora mirrors, tried them out for
> F12-F14 and same thing happened as when I used the liveusb image.
> Tried the F15 efidisk.img from the kernel.org mirror, and holy smoke, it
> boots! What happens is when the system boots the screen is all scrambled,
> although I can make out what would normally be the Tux logo and the grey
> text scrolling by. Then I get to the familiar blue/grey/red screen in the
> Fedora text installer. If I hit the arrow keys on my keyboard the red part
> moves up/down, which I know from experience is the menu for selecting the
> installer language. But since the graphics are all scrambled, I can't
> actually read anything, and thus I can't proceed with the installation.
> So I think if I can boot the F15 installer in a mode where the graphics
> aren't all messed up, I can install. I've tried using the "nomodeset"
> option on the kernel line (i.e. by hitting 'e' in GRUB and editing), but
> no dice -- I still get the scrambled screen. To the best of my knowledge,
> the videocard is an NVIDIA GeForce 320M. I realize I probably missed the
> nouveau graphics test day today, but maybe there's someone here who can
> help me out.
> Thanks!

look at http://fedoraproject.org/wiki/Anaconda/Options i see two options.  try 
and write a kickstart file that sets up everything for you or  use vnc, pass 
enough options so that network is setup, keyboard etc detected,  and vnc can 
start so you can connect. 

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part.
Url : http://lists.fedoraproject.org/pipermail/test/attachments/20110222/b16f3ec3/attachment.bin 

More information about the test mailing list