kernel-PAE- update problem

Petrus de Calguarium pgueckel at
Sat Jul 9 16:50:03 UTC 2011

I just updated to the new (testing) kernel.

When it was done, a message appeared that grubby was unable to find a 
suitable template. Thinking nothing of this, I rebooted the system, 
and instead of the usual graphical grub menu appearing, a black screen 
with a grub prompt appeared. I was forced to manually enter the root, 
kernel and initramfs. Fortunately, I know how to do this, but what I 
noticed was that the initramfs for the new kernel was missing, so I 
had to boot the previous kernel.

The system booted but I got a lot of strange messages first. I presume 
these were systemd errors. At first it appeared that the system would 
not boot, due to the severity of the messages that appeared, but then 
it all progressed anyway.

Once booted (old kernel), I examined grub.conf and saw that the entry 
for the new kernel was not there. I ran yum-complete-transaction, and 
there was one pending transaction that completed successfully in a 
split second, but this did not cause initramfs for the new kernel to 
be created, nor did it cause the missing grub.conf entry for the new 
kernel to appear.

Then, I decided to install grub again, so I ran grub-install /dev/sda 
and I got three messages about /dev/root not existing and a fourth one 
(I forgot what it said). Then, I decided to install grub using the 
grub shell, and I was told that the stage1 and stage 2 were out of 
sync, or something like that (I cannot recall the exact message, but 
it failed).

So, I downgraded grub and this time I was able to use the grub shell, 
but still not grub-install (same errors about /dev/root and the other 

Since the initramfs for the new kernel was not there, I uninstalled 
this kernel and reinstalled it. Again, grubby gave me the strange 
message about the missing template and grub.conf was not updated, but 
the initramfs was created. I manually entered the missing information 
into grub.conf. Then, I upgraded grub again. Now, the new kernel boots 

What was going on here? Why did the initramfs not get created? Why is 
grub not updating grub.conf? Why were stage1 and stage 2 of grub not 
in sync (or whatever it was)? Why can I not install grub using grub-
install (but I can using the grub shell)?

More information about the test mailing list