[solved] On making a proper kernel for gnome-shell

Jason D. Clinton me at jasonclinton.com
Fri Mar 11 22:25:24 UTC 2011

On Fri, Mar 11, 2011 at 16:05, Jonathan Corbet <corbet-ft at lwn.net> wrote:
> Found it.  The root cause is that I was unable to open /dev/dri/card0.  In
> the end, every system management problem in existence can be diagnosed with
> strace...  I added myself to the "video" group and everything is happy now.
> I have not delved further, but I am guessing that the problem is that I
> don't build SELinux into my kernels.  I've never had anything break as the
> result of leaving out SELinux before...  Worth noting, I bet I'm not the
> only one who will run into this one.

Actually, it's probably somehow related to ACL's which are supposed to
automatically be append to the device node in question on ConsoleKit
activation of the user session:

[jclinton at jclinton-laptop ~]$ getfacl /dev/dri/card0
getfacl: Removing leading '/' from absolute path names
# file: dev/dri/card0
# owner: root
# group: video

So, you're probably going to have other permissions related issues
until you track down the root cause. The first time I ran in to this
historically was plugging my shiny new Nexus One in to my laptop and
being unable to come up with a method of running adb against it that
didn't involve root access... until I delved in to the interesting
intersection of udev and the CK database.

Maybe you're missing ACL's support, generally?

More information about the test mailing list