Release-blocker questions

Andre Robatino robatino at
Sun May 1 18:53:30 UTC 2011

BeartoothHOS <beartooth <at>> writes:

> 	It seems not to here :
> [root <at> Hbsk1 ~]# rpm -q mutter
> mutter-3.0.1-3.fc15.i686
> [root <at> Hbsk1 ~]#
> but I still get the frowning computer when I try to log in.
> 	I did gnome-session-properties twice, both as root and as user, 
> setting the option to save sessions both ways -- and none let me log in.
> 	I rebooted, and tried again. Still no joy.

gnome-session-properties sets the properties for whichever user runs it, so you
shouldn't run it as root (since it's a bad idea to log in graphically as root
anyway - in fact, if you did so in the past, it might be causing some of the
problems you're having). Some of what I read about .ICEauthority on Google
indicated that it might be a permissions problem, so you could try logging into
a VT and checking for files in your home directory not owed by you (for example,
files owned by root):

find ~myusername ! -user myusername -print

If you find such files, change the permission by su'ing to root and run

chown -R -c myusername:myusername ~myusername

or just change them individually in case there are manually created files that
are actually supposed to be owned by someone else (normally there wouldn't be).

BTW, I did have some trouble getting session saving to work even after updating
mutter, and had to do some stumbling around, deleting the files in
~/.config/gnome-session/saved-session, unchecking and rechecking the option in
g-s-p, etc. before it would work. It's still not perfect as it doesn't always
remember what workspace each application was in (for example, having one
gnome-terminal in workspace 1 and another in workspace 2, logging out and back
in puts both of them in workspace 1) but at least I can log in normally.

More information about the test mailing list