My Fedora 15 beta experiences so far

Stephen John Smoogen smooge at
Fri May 13 19:03:22 UTC 2011

On Fri, May 13, 2011 at 11:55,  <alan at> wrote:
> I have to admit, this is the most painful Fedora installation I have ever
> done. (And I have used them all.)
> The networking came up as IPv6 *only*. My router does not do IPv6 and my
> ISP (Qwest) does not know when their network ever will. In order to get it
> to work I had to hack files in /etc/sysconfig and use dhclient to get an
> address since the Network Manager applet is dumbed down to absolute
> worthlessness. (More on that later.)  The networking problems seem to have
> been fixed, but there were far too many of them. (Having no default route
> for fixed IP addresses was a pain.)
> If I were to grade Gnome 3 it would be "incomplete".  It looks nice, but
> it is missing large chunks of functionality. For example, network
> configuration is useless. Gnome screen saver's config panel is no where to
> be found. To switch the desktop with a mouse now takes 2-3 clicks where it
> used to take one. There are no applets to be found. The desktop is bare,
> unless you use an the Gtweakui program to hack it. (Which most users will
> not ever know about since it is not installed by default.) The option to
> use the "classic style" is a lie. It is still Gnome 3, but with a
> kinda-sorta Gnome 2 look. (With all the above still missing.)
> Gnome 2 had similar problems. When it was first released, it was dumbed
> down and was lacking most of the functionality of Gnome 1.  Now that they
> finally have Gnome 2 working well I guess they felt they had to pitch it
> all out and start over. This new design looks nice, but is not that
> usable. A UI should make it easier to get to what you want to do, not add
> useless mouse clicks.
> My biggest complaint though is the kernel. I am getting kernel panics in
> ext4! (When I can get a log I will post it. It does not get written to
> disk since the filesystem dies.)
> Another thing... I cannot find a way to disable the Nouveau kernel module.
> I have tried all the methods that worked before (rdblacklist and the
> modules blacklist.) Nothing seems to work. I am going to have to rebuild
> the kernel rpm. Why is this more difficult?
> The reason I went to this version when I did was due to a sort of double
> bind.  Fedora 13 uses 2.6.34. USB3 does not work well with that kernel. (I
> have already spoken with the maintainer. She thinks she knows the cause
> and is going to backport the patch.) 2.6.35+ works with USB3, but another
> program I use often does not work with my hand-rolled kernel. (Threading
> issue.) Upgrade seemed like a good option. Now I am not so sure.
> Hopefully I will be able to make this thing work.  I may have to go to KDE
> for a bit until the Gnome developers finish writing it. (How long that
> will take, I have no idea...)

What kind of hardware is this (smolt id?) what kind of local network
setup (my test boxes have gotten DHCP correctly so far but it is a
limited setup)?

Stephen J Smoogen.
"The core skill of innovators is error recovery, not failure avoidance."
Randy Nelson, President of Pixar University.
"Let us be kind, one to another, for most of us are fighting a hard
battle." -- Ian MacLaren

More information about the test mailing list