F-15 Branched report: 20110515 changes

Tom Callaway tcallawa at redhat.com
Tue May 17 15:33:35 UTC 2011


Lately, I've been trying to resolve as many of these as reasonably
possible. Here's what I know:

On 05/15/2011 07:03 PM, Branched Report wrote:
> Compose started at Sun May 15 13:15:23 UTC 2011
> 
> Broken deps for x86_64
> ----------------------------------------------------------
> 	db4o-7.4-2.fc13.x86_64 requires mono(Mono.GetOptions) = 0:2.0.0.0

I have a fixed version of 8.0 almost ready.

> 	dh-make-0.55-3.fc15.noarch requires debhelper

Not sure how this is in Fedora, since it doesn't appear that debhelper
ever was: https://bugzilla.redhat.com/show_bug.cgi?id=591190

> 	file-browser-applet-0.6.6-1.fc15.x86_64 requires libpanel-applet-2.so.0()(64bit)
> 	glunarclock-0.34.1-1.fc14.x86_64 requires libpanel-applet-2.so.0()(64bit)
> 	gnome-applet-bubblemon-2.0.15-1.fc13.x86_64 requires libpanel-applet-2.so.0()(64bit)
> 	gnome-applet-cpufire-1.6-3.fc14.x86_64 requires libpanel-applet-2.so.0()(64bit)
> 	gnome-applet-globalmenu-0.7.9-1.fc15.x86_64 requires libpanel-applet-2.so.0()(64bit)
> 	gnome-applet-grandr-0.4.1-2.fc12.x86_64 requires libpanel-applet-2.so.0()(64bit)
> 	gnome-applet-music-2.5.1-5.fc15.x86_64 requires libpanel-applet-2.so.0()(64bit)
> 	gnome-applet-sensors-2.2.7-4.fc15.i686 requires libpanel-applet-2.so.0
> 	gnome-applet-sensors-2.2.7-4.fc15.x86_64 requires libpanel-applet-2.so.0()(64bit)
> 	gnome-applet-sshmenu-3.18-3.fc15.noarch requires ruby(panelapplet2)
> 	gnome-applet-window-picker-0.5.8-2.fc14.x86_64 requires libpanel-applet-2.so.0()(64bit)
> 	1:gnome-applets-2.32.0-3.fc15.x86_64 requires libpanel-applet-3.so.0()(64bit)
> 	1:gnome-applets-2.32.0-3.fc15.x86_64 requires libpanel-applet-2.so.0()(64bit)
> 	1:gnome-applets-2.32.0-3.fc15.x86_64 requires libgweather.so.1()(64bit)
> 	gnome-netstatus-2.28.2-1.fc15.x86_64 requires libpanel-applet-2.so.0()(64bit)
> 	gnome-pilot-conduits-2.32.1-2.fc15.x86_64 requires libgpilotd.so.5()(64bit)
> 	gnome-pilot-conduits-2.32.1-2.fc15.x86_64 requires libgpilotdcm.so.4()(64bit)
> 	gnome-pilot-conduits-2.32.1-2.fc15.x86_64 requires libgpilotdconduit.so.3()(64bit)
> 	gnome-python2-applet-2.32.0-1.fc14.x86_64 requires libpanel-applet-2.so.0()(64bit)
> 	gnome-python2-brasero-2.32.0-1.fc14.x86_64 requires libbrasero-media.so.1()(64bit)
> 	gnome-python2-brasero-2.32.0-1.fc14.x86_64 requires libbrasero-burn.so.1()(64bit)
> 	gnome-python2-evince-2.32.0-1.fc14.x86_64 requires libevview.so.3()(64bit)
> 	gnome-python2-evince-2.32.0-1.fc14.x86_64 requires libevdocument.so.3()(64bit)
> 	gnome-python2-evolution-2.32.0-1.fc14.x86_64 requires libcamel-1.2.so.19()(64bit)
> 	gnome-python2-gdl-2.25.3-22.fc15.x86_64 requires libgdl-1.so.3()(64bit)
> 	gnome-python2-totem-2.32.0-1.fc14.x86_64 requires libgnome-media-profiles.so.0()(64bit)

All of these are broken because of the shift to GNOME 3 and the loss of
applet support.

> 	gnome-rdp-0.2.3-6.fc12.x86_64 requires mono(Mono.Data.SqliteClient) = 0:2.0.0.0

Newer versions of gnome-rdp than 0.2.3 are very very broken. As in "I
don't have any code to create the database that the application depends
upon" broken. Upstream bugreporting redirects to the ubuntu package.

So, I just fixed this C# mess up in 0.2.3 and made an update:
https://admin.fedoraproject.org/updates/gnome-rdp-0.2.3-8.fc15

> 	gnotime-2.3.0-8.fc15.x86_64 requires libgtkhtml-3.15.so.19()(64bit)
> 	gnubiff-2.2.13-4.fc15.x86_64 requires libpanel-applet-2.so.0()(64bit)

All of these are broken because of the shift to GNOME 3 and the loss of
applet support.

> 	gnustep-back-0.18.0-4.fc14.x86_64 requires libobjc.so.2()(64bit)
> 	gnustep-back-0.18.0-4.fc14.x86_64 requires libgnustep-base.so.1.20()(64bit)
> 	gnustep-examples-1.3.0-4.fc15.x86_64 requires libgnustep-base.so.1.20()(64bit)
> 	gnustep-examples-1.3.0-4.fc15.x86_64 requires libobjc.so.2()(64bit)
> 	gnustep-gui-0.18.0-2.fc14.x86_64 requires libgnustep-base.so.1.20()(64bit)
> 	gnustep-gui-0.18.0-2.fc14.x86_64 requires libobjc.so.2()(64bit)
> 	gnustep-gui-libs-0.18.0-2.fc14.i686 requires libobjc.so.2
> 	gnustep-gui-libs-0.18.0-2.fc14.i686 requires libgnustep-base.so.1.20
> 	gnustep-gui-libs-0.18.0-2.fc14.x86_64 requires libgnustep-base.so.1.20()(64bit)
> 	gnustep-gui-libs-0.18.0-2.fc14.x86_64 requires libobjc.so.2()(64bit)

All of GNUStep seems to be broken because of issues with the new GCC
ObjC support, but I don't know Objective C, and don't really want to
learn it.

> 	gold-2.1.12.2-5.fc15.noarch requires perl(Data::Properties)

Someone needs to package
http://search.cpan.org/~ix/Data-Properties-0.02/. Alternately, figure
out what script in gold

> 	gorm-1.2.12-2.fc15.i686 requires libobjc.so.2
> 	gorm-1.2.12-2.fc15.i686 requires libgnustep-base.so.1.20
> 	gorm-1.2.12-2.fc15.x86_64 requires libgnustep-base.so.1.20()(64bit)
> 	gorm-1.2.12-2.fc15.x86_64 requires libobjc.so.2()(64bit)

Don't know Objective C, don't really want to learn it.

> 	gpx-viewer-0.2.0-3.fc14.x86_64 requires libchamplain-0.6.so.0()(64bit)
> 	gpx-viewer-0.2.0-3.fc14.x86_64 requires libchamplain-gtk-0.6.so.0()(64bit)
> 	gpx-viewer-0.2.0-3.fc14.x86_64 requires libgdl-1.so.3()(64bit)

I posted a patch to this mailing list that gets this... thing building
and running, but it is less stable than some of the block towers my 15
month old son builds, so I do not have confidence in building it as an
update.

> 	gyachi-plugin-libnotify-1.2.10-3.fc14.x86_64 requires libnotify.so.1()(64bit)

* use libv4l1 header instead of obsolete kernel header
* fix gtk compile issues
* support notify 0.7
* cleanup desktop file (bz 616122)
* resolve broken dependencies
* fix FTBFS

https://admin.fedoraproject.org/updates/gyachi-1.2.10-5.fc15

> 	honeyd-1.5c-13.fc15.x86_64 requires libevent-1.4.so.2()(64bit)

honeyd depends very closely on internals of libevent, hence, it doesn't
work with libevent2. This is a bit ironic because the upstream author of
honeyd is also the author of libevent. Upstream claims they are working
on a new version of honeyd that uses libevent2.

> 	intellij-idea-9.0.1.94.399-12.fc15.x86_64 requires commons-collections

This code badly needs to be updated. Unfortunately, like most things
Java, I was three levels deep into dependencies (which also needed to be
updated) when I finally gave up (fwiw, the point where I gave up is when
I determined that updated gant uses "gradle" to build, which is not in
Fedora yet).

> 	libopenvrml-0.18.6-4.fc14.1.i686 requires libboost_thread-mt.so.1.44.0
> 	libopenvrml-0.18.6-4.fc14.1.i686 requires libboost_filesystem-mt.so.1.44.0
> 	libopenvrml-0.18.6-4.fc14.1.x86_64 requires libboost_filesystem-mt.so.1.44.0()(64bit)
> 	libopenvrml-0.18.6-4.fc14.1.x86_64 requires libboost_thread-mt.so.1.44.0()(64bit)
> 	libopenvrml-gl-0.18.6-4.fc14.1.i686 requires libboost_thread-mt.so.1.44.0
> 	libopenvrml-gl-0.18.6-4.fc14.1.i686 requires libboost_filesystem-mt.so.1.44.0
> 	libopenvrml-gl-0.18.6-4.fc14.1.x86_64 requires libboost_filesystem-mt.so.1.44.0()(64bit)
> 	libopenvrml-gl-0.18.6-4.fc14.1.x86_64 requires libboost_thread-mt.so.1.44.0()(64bit)

https://admin.fedoraproject.org/updates/openvrml-0.18.8-1.fc15

> 	lock-keys-applet-1.0-21.fc15.x86_64 requires libpanel-applet-2.so.0()(64bit)
> 	meego-panel-datetime-0.3.2-5.fc15.x86_64 requires libgweather.so.1()(64bit)

All of these are broken because of the shift to GNOME 3 and the loss of
applet support.

> 	meego-panel-status-0.3.2-2.fc15.i686 requires libchamplain-0.8.so.1
> 	meego-panel-status-0.3.2-2.fc15.x86_64 requires libchamplain-0.8.so.1()(64bit)

Needs to be ported to newer libchamplain.

> 	monodevelop-boo-2.4-1.fc14.x86_64 requires mono(Boo.Lang.Interpreter) = 0:2.0.9.2
> 	monodevelop-boo-2.4-1.fc14.x86_64 requires mono(Boo.Lang) = 0:2.0.9.2
> 	monodevelop-boo-2.4-1.fc14.x86_64 requires mono(Boo.Lang.CodeDom) = 0:2.0.9.2
> 	monodevelop-boo-2.4-1.fc14.x86_64 requires mono(Boo.Lang.Compiler) = 0:2.0.9.2

Hooray for Boo making changes and not documenting the new API anywhere.
I think my changes work, they seem to work fine in my limited testing.
https://admin.fedoraproject.org/updates/monodevelop-boo-2.4-6.fc15

> 	network-manager-netbook-1.8-3.fc15.x86_64 requires libnm-util.so.1()(64bit)
> 	network-manager-netbook-1.8-3.fc15.x86_64 requires libnm-glib.so.2()(64bit)

Can't rebuild because of mutter dependency loop.

> 	openvpn-auth-ldap-2.0.3-6.fc12.x86_64 requires libobjc.so.2()(64bit)

Don't know Objective C, don't really want to learn it.

> 	openvrml-java-0.18.6-4.fc14.1.x86_64 requires libboost_filesystem-mt.so.1.44.0()(64bit)
> 	openvrml-java-0.18.6-4.fc14.1.x86_64 requires libboost_thread-mt.so.1.44.0()(64bit)
> 	openvrml-javascript-0.18.6-4.fc14.1.x86_64 requires libboost_filesystem-mt.so.1.44.0()(64bit)
> 	openvrml-javascript-0.18.6-4.fc14.1.x86_64 requires libboost_thread-mt.so.1.44.0()(64bit)
> 	openvrml-nodes-0.18.6-4.fc14.1.x86_64 requires libboost_filesystem-mt.so.1.44.0()(64bit)
> 	openvrml-nodes-0.18.6-4.fc14.1.x86_64 requires libboost_thread-mt.so.1.44.0()(64bit)
> 	openvrml-xembed-0.18.6-4.fc14.1.x86_64 requires libboost_filesystem-mt.so.1.44.0()(64bit)
> 	openvrml-xembed-0.18.6-4.fc14.1.x86_64 requires libboost_thread-mt.so.1.44.0()(64bit)

https://admin.fedoraproject.org/updates/openvrml-0.18.8-1.fc15

> 	ovaldi-5.6.4-1.fc14.x86_64 requires librpm.so.1()(64bit)
> 	ovaldi-5.6.4-1.fc14.x86_64 requires librpmio.so.1()(64bit)

https://admin.fedoraproject.org/updates/ovaldi-5.9.1-1.fc15

> 	pcp-import-sheet2pcp-3.5.0-1.fc15.1.x86_64 requires perl(Spreadsheet::Read)

Someone needs to package
http://search.cpan.org/~hmbrand/Spreadsheet-Read-0.41/ .

> 	perl-Gtk2-MozEmbed-0.08-7.fc15.3.x86_64 requires gecko-libs = 0:2.0

Needs to be ported to the new xulrunner.

> 	pfstools-octave-1.8.1-4.fc15.x86_64 requires liboctave.so()(64bit)
> 	pfstools-octave-1.8.1-4.fc15.x86_64 requires libcruft.so()(64bit)
> 	pfstools-octave-1.8.1-4.fc15.x86_64 requires liboctinterp.so()(64bit)

https://admin.fedoraproject.org/updates/pfstools-1.8.3-1.fc15

> 	php-facedetect-1.0.0-6.fc14.x86_64 requires libcv.so.2.1()(64bit)
> 	php-facedetect-1.0.0-6.fc14.x86_64 requires libcxcore.so.2.1()(64bit)
> 	php-facedetect-1.0.0-6.fc14.x86_64 requires libhighgui.so.2.1()(64bit)
> 	php-facedetect-1.0.0-6.fc14.x86_64 requires libcvaux.so.2.1()(64bit)

https://admin.fedoraproject.org/updates/php-facedetect-1.0.1-3.fc15

> 	qtgpsc-0.2.3-6.fc12.x86_64 requires libgps.so.18()(64bit)

The last time I looked at this thing, I wanted to remove my eyes with a
melon baller. I'm content to let it be broken, heck, I'd even advocate
for it to be removed entirely.

> 	sear-0.6.3-14.fc12.x86_64 requires liberis-1.3.so.15()(64bit)

https://admin.fedoraproject.org/updates/sear-0.6.3-18.fc15

> 	sunbird-1.0-0.33.b2pre.fc15.x86_64 requires libnotify.so.1()(64bit)

Probably should be removed/obsoleted by lightning/thunderbird.

> 	uim-gnome-1.6.1-1.fc15.x86_64 requires libpanel-applet-2.so.0()(64bit)

Broken because of the shift to GNOME 3 and the loss of applet support.

> 	xfce4-globalmenu-plugin-0.7.9-1.fc15.x86_64 requires libxfce4panel.so.1()(64bit)

Comes from gnome-globalmenu, which depends on the old GNOME 2 panel.

> 	xiphos-3.1.4-3.fc15.x86_64 requires libgtkhtml-3.15.so.19()(64bit)
> 	xiphos-3.1.4-3.fc15.x86_64 requires libgtkhtml-editor-3.14.so.0()(64bit)

Tried to port this to GNOME 3. Failed. Code is too old and crufty,
depends heavily on libglade.

~tom

==
Fedora Project


More information about the test mailing list