Mock/pungi error - stumped!

James Laska jlaska at redhat.com
Mon May 23 14:37:03 UTC 2011


On Sat, 2011-05-21 at 22:07 +0100, mike cloaked wrote:
> I have been trying to build f15 from the development/f15 plus f15
> updates repos using pungi from a mock chroot.  I have been doing this
> process since f11 days.
> 
> I use a standard .cfg file to create the chroot  with the mock -r
> command as user with only changes to the repo definitions, and then
> run pungi in the chroot with a kickstart file with some packages
> removed plus a few additional packages to include in the iso that
> builds.
> 
> However I have a problem with the build that I can't resolve.
> The machine running the build is f13 up to date, and the command I use
> to run pungi is as follows:
> pungi --nosource --nodebuginfo -G -C -B -I --flavor Fedora --name
> Fedora-15 -c /usr/share/spin-kickstarts/fedora-install-f15-mc.ks
> --force
> 
> I have also cleaned out the /var/cache/mock area as well as
> /var/lib/mock before setting up the chroot and then installing pungi
> and spin-kickstarts in the chroot, and then running the pungi command.
> 
> However the build proceeds to the point in the logfile with the last
> few entries:
> 
> pylorax.yumhelper.DEBUG: removed
> /work/i386/yumroot/installroot//usr/share/omf/zenity/zenity-zh_CN.omf
> pylorax.DEBUG: fedora-15-logos  ['/etc/*', '/usr/share/firstboot/*',
> '/usr/share/gnome-screensaver/*', '/usr/share/icons/Bluecurve/*',
> '/usr/share/icons/oxygen/*', '/usr/share/pixmaps/*',
> '/usr/share/plymouth/*']
> pylorax.yumhelper.ERROR: cannot erase fedora-15-logos: Package not installed
> pylorax.INFO: cleaning up python files
> pylorax.INFO: creating the initrd
> pylorax.images.INFO: creating required directories
> pylorax.images.INFO: copying kernel image
> pylorax.images.INFO: compressing the install tree
> 
> It seems to hang for up to 12 hours at the final compression (before I
> kill the process) and this seems all wrong - at least it never used to
> do this and the build used to complete in about an hour and a half on
> this same machine.
> 
> Any ideas what I might be doing wrong?

Hmm, no idea off-hand.  You probably already did this, but double check
the versions of pungi and lorax being used inside the chroot.  They have
changed recently, so make sure you are using the latest versions of
each.  Are you able to upload your mock root.log for review?

I've also cc'd Martin Gracik who maintains lorax to see if he has any
debugging tips.

Thanks,
James
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
Url : http://lists.fedoraproject.org/pipermail/test/attachments/20110523/6dde7f7f/attachment.bin 


More information about the test mailing list