DVD F14 -> F15 Problems

He Rui rhe at redhat.com
Mon May 30 10:44:39 UTC 2011

On Sun, 2011-05-29 at 13:44 -0400, Garry T. Williams wrote:
> I upgraded to F15 from F14 using the DVD yeterday.  I experienced a
> few glitches:
> 1.  I was not asked to include the updates repository during the
> update process.  Sad.  Now I will have to do an update after first
> boot.
> 2.  This is apparently a general problem not really related to the
> specific upgrade.  I noticed that the upgrade process was slow.  The
> disk just churned forever.  After booting for the first time, I ran
> yum erase on my debuginfos so that the subsequent yum update would not
> pull those in.  This erase command took way too long.
> I think the rpm database gets into a state that needs attention.  This
> fixed it:
>     sudo rm -f /var/lib/rpm/__db.001 /var/lib/rpm/__db.002 \
> 	    /var/lib/rpm/__db.003 /var/lib/rpm/__db.004
>     sudo rpm --rebuilddb
> After that, yum operations sped up an order of magnitude.
> 3.  The first boot ended at multiuser.target instead of
> graphical.target.  When I entered the command
>     sudo systemctl isolate graphical.target
> kdm came up and allowed a normal desktop login.
> Hmmm.  I compared another system that I upgraded using preupgrade and
> that one had the correct graphical.target file linked in
> /etc/systemd/system .  So I had to do this to correct the problem:
>     sudo rm /etc/systemd/system/default.target
>     sudo ln -s /lib/systemd/system/runlevel5.target \
> 	    /etc/systemd/system/default.target
> I don't know why this happened with the DVD upgrade and not with the
> preupgrade upgrade.

Was your default init level on Fedora-14 3? Then if you changed the
default runlevel by modifying the file /etc/inittab, those changes
wouldn't affect the configured systemd default target. See 




FAS Name: Rhe 
Timezone: UTC+8
TEL: 86-010-62608141
IRC nick: rhe #fedora-qa #fedora-zh

More information about the test mailing list