Issues encountered upgrading with yum from Fedora 16 to Fedora 17

Adam Williamson awilliam at
Mon Apr 2 07:38:50 UTC 2012

On Sun, 2012-04-01 at 00:16 -0400, Jonathan Kamens wrote:
> Hi everyone,
> I just upgraded my system from Fedora 16 to Fedora 17 using yum as
> described at
> Here are my
> notes from the experience. I'm not really sure which of these to file
> bugs about; any feedback on that score would be appreciated.
> The Fedora 16 -> Fedora 17 instructions say that the upgrade requires
> at least dracut-013-22.fc16, but "yum  update" didn't get me that
> version, so I had to download and install it manually from koji.
> Presumably this is because it just hadn't been pushed to the yum repo
> yet and this problem will rectify itself soon enough.
> I could have sworn I typed the "dracut --force --add convertfs"
> command properly and that it actually did something, but apparently
> not, because when I rebooted afterward I still had my old initramfs. I
> ran the same command again after that reboot and then rebooted a
> second time, and this time it worked. I guess I must have typed the
> command wrong or something, but really, I could have sworn I didn't.

You must have done. I did it four times yesterday and it worked fine
each time. Did you forget to pass the required kernel parameters the
first time? Just adding the convertfs script to the initramfs does
nothing on its own, you have to pass the kernel parameters specified in
the instructions to make the conversion actually happen.

> After the upgrade, both named.service and dhcpd.service were disabled
> in systemd, even though they were both enabled prior to the upgrade.
> Perhaps this is because named and dhcpd were switched to systemd in
> F17? I imagine other people are going to run into this issue and be
> irritated by it. Note that the upgrading with yum page listed above
> mentions recording enabled services before the upgrade and restoring
> them afterward for the Fedora 15 -> Fedora 16 upgrade, but not for the
> Fedora 16 -> Fedora 17 upgrade. If some services are being converted
> from initscripts to systemd in F17, they need to be called out on this
> page.

Yes, this is just the same as F15->F16, we should probably just copy
that text into the F16->F17 section.

> Prior to the upgrade my window title bars had minimize, maximize, and
> close buttons. After the upgrade only the close button remained, and I
> had to use gnome-tweak-tool to put back the other buttons, just as I
> had long ago to get them in the first place. Is it a bug that this
> configuration setting was lost and had to be restored? Is it possible
> that gnome-shell reverted to its default settings because it was
> crashing or something like that?
> Similarly, I had mouse focus configured prior to the upgrade, but
> after the upgrade gnome-shell reverted to click focus and I had to
> tweak it again.

This sounds like they got converted from gconf to dconf across the
upgrade, I think.

> I suspected this might be due to the fact that I had the dock
> extension enabled, but I disabled it and the problem didn't go away.
> Might it have something to do with the fact that I have two monitors?
> Should I file a bug? Note that if I restart multiple times, it does
> not shift further and further; it only shifts as far as shown above.

I have two monitors and I've never seen that. But in general, always
disable all extensions and reproduce an issue before filing it against
Shell. Might be best just to test with a clean user account. It may be a
graphics driver issue rather than a Shell issue.

> I noticed in gnome-tweak-tool that I had no shell theme installed.
> There are a number of gnome-shell-them-* RPMs, but apparently none of
> them is installed by default in the GNOME Desktop Environment yum
> group. Should one of them be?

No, we don't intend to provide alternative themes OOTB. You want themes,
install them.
Adam Williamson
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | adamwfedora

More information about the test mailing list