Repeated F17 gnome-shell crash, with fix

Jonathan Kamens jik at
Thu Apr 5 02:10:52 UTC 2012

I tried to restart gnome-shell this evening with Alt-F2 r RET, and it 
crashed on restart. Then it crashed again when I tried to log in again. 
Then several more times. Then again after I restarted.

Seeing as how I had no other choice if I wanted to actually log in, I 
downloaded and installed all of the debuginfos in a VT, debugged the 
crash, and came up with a fix, which I've submitted as a patch in bugzilla:

I noticed that the notification that bugzilla sent out about this bug 
went to a rather paltry list of people. I'm therefore sending this email 
to the test list in the hope that it will be noticed by someone in a 
position to ensure that this bug is fixed in the final F17 release, so 
that other people who don't actually know how to analyze core dumps and 
fix bugs won't end up completely unable to log in.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the test mailing list