Imagemagick dependencies that don't seem to be in the F17 dependency report

stan gryt2 at q.com
Thu Apr 12 18:07:37 UTC 2012


On Thu, 12 Apr 2012 17:36:43 +0200
Michael Schwendt <mschwendt at gmail.com> wrote:

> On Thu, 12 Apr 2012 07:52:22 -0700, S (stan) wrote:
> 
> > These are dependency errors I get when I try to update to the latest
> > version of ImageMagick.  I don't see them in the branched report, so
> > thought I would report them.
> 
> http://bugz.fedoraproject.org/ImageMagick
> 
> There is ongoing work on publishing upgrades of ImageMagick, which are
> ABI incompatible with earlier releases. It's not clear to me why
> rebuilds of dependencies are missing, but it seems some package
> maintainers don't respond, and the entire [co]-maintainer setup to do
> such rebuilds is lacking.

Thanks for the clarification.
 
> For multiple versions of some software to be installable in parallel,
> it would be necessary to resolve conflicts in the packages *and*
> rename either package, so the new one does not replace the older one.
> This can result in a lot of work, which isn't worth effort.

Ah yes, a major issue.  Hmmm, doesn't seem to be a trivial solution to
this.  Probably would require some sort of time versioning associated
with files.

> Especially not if the old release suffers from vulnerabilities. You
> don't want to keep it. You want to replace it quickly.

The thing is, though, that the update is being held up by these
dependencies.  It seems to me it would be better to let the updates
update as soon as they are available, and let dependent packages update
as they can.  This would plug the most holes the soonest.  i.e. while
we're waiting for dependencies to get updated with the fixed package,
the fixed package that is ready can't install.


More information about the test mailing list