F17 beta doesnt automount my SD reader or pen drives

Adam Williamson awilliam at redhat.com
Sun Apr 22 21:34:59 UTC 2012


On Sun, 2012-04-22 at 17:27 -0300, Fernando Cassia wrote:
> What would be the right procedure to test why F17 doesnt' mount my sd
> card reader?
> 
> F16 on the same machine worked just fine.
> Although on previous Fedora versions (F10 or thereabouts) I used to
> have to disable SELinux to get the card mounted as I always got a
> SELInux exception when plugging my SD card USB reader to any USB port,
> and it outright refused to mount an Eye-Fi wifi SD card into the card
> reader.

If you get an SELinux denial, file it as a bug using the SELinux
troubleshooter.

> # lsusb
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 001 Device 003: ID 1a40:0101 TERMINUS TECHNOLOGY INC. USB-2.0 4-Port HUB
> Bus 002 Device 002: ID 0aec:3260 Neodio Technologies Corp. 7-in-1 Card Reader
> Bus 001 Device 005: ID 152d:2338 JMicron Technology Corp. / JMicron
> USA Technology Corp. JM20337 Hi-Speed USB to SATA & PATA Combo Bridge
> 
> On F17b I tried to disable SELinux to see if it made any difference,
> with the usual procedure but it didn't work
> 
> # echo 0 >/selinux/enforce
> bash: /selinux/enforce: No such file or directory

That is not 'the usual procedure'. The usual procedure is 'setenforce
Permissive', boot with 'enforcing=0' or 'selinux=0' (but the last is a
last resort to be used only if permissive mode isn't enough).
-- 
Adam Williamson
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net



More information about the test mailing list