kernel-3.3.4 doesn't compile when customized to disable EFI

stan gryt2 at
Mon Apr 30 23:12:17 UTC 2012

On Mon, 30 Apr 2012 12:54:02 -0400
Josh Boyer <jwboyer at> wrote:

> On Mon, Apr 30, 2012 at 12:56 PM, stan <gryt2 at> wrote:
> > I always compile the Fedora kernel package with a custom config that
> > tunes it for my system.  The config file that worked on the 3.3.2
> > kernels fails on the 3.3.4 kernels, complaining that CONFIG_FB_EFI
> > is not defined.  I have no EFI, so it is turned off completely in my
> > config file, but it looks like I'll have to enable it to get the
> > 3.3.4 kernel to compile.
> >
> > I thought about opening a bugzilla, but I don't think Fedora kernel
> > developers have any interest in failures of custom configurations.
> >  I imagine there is enough for them to worry about without that.
> >  :-) This is more in the way of a heads up for other custom kernel
> > compilers.
> If this happens on a vanilla 3.3.4 kernel, you could always report the
> exact build failure to the upstream stable maintainers.  They'd be in
> a position to fix it.
> If it _doesn't_ happen with a vanilla 3.3.4 kernel, please file a bug
> against the Fedora kernel.  It means we have a patch added that is
> probably either working it's way upstream and is broken, or is a stale
> version of something like that.

I'm not sure whether it happens with a vanilla kernel, as I don't
compile that.  I use the procedure from the Fedora wiki for compiling
from the src.rpm, and it normally works just fine.  I'd have to figure
out how to compile the vanilla kernel, as it seems to be included in
the src.rpm.  Maybe it is as simple as make menuconfig, make.

I've already turned on EFI and eliminated the EFI error, but now I'm
getting an error as it tries to build the RPM, saying
+ sort -u req.list
sort: open failed: req.list: No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.IFiR0D (%build)
    Bad exit status from /var/tmp/rpm-tmp.IFiR0D (%build)

I haven't done any research on this one yet, so it might be something
trivial.  The procedure I use worked without issue on Fedora 3.3.2
kernels, so something has changed.

If you still think it it worthwhile to open a bugzilla, I can use the
previous .config file and generate the error output again in order to
put it in the bugzilla.

Thanks for your response.

More information about the test mailing list