Braden McDaniel braden at
Tue May 1 21:29:31 UTC 2012

On 5/1/12 1:49 PM, Tom Horsley wrote:
>>> I'm running dovecot on Fedora 16.  I seem unable to create new IMAP
>>> subfolders from clients; and this is possibly associated with the most
>>> recent dovecot update on F16.
>> Yes I also ran into the above issue when I lost my backups (HD failed)
>> and had to reinstall a workstation.
> I'm running f16, and just tried making a new folder via dovecot
> and it worked fine for me. I have all the latest updates as far
> as I know. Haven't tried it on f17 yet.

Thank you for the data point.

I discovered what my problem was.  I have a local user on my mail server 
(because I haven't yet sat down and figured out how to tell dovecot 
about my LDAP users) whose default group was inconsistent with that of 
the corresponding LDAP user.  And what led directly to the problem (I 
suspect) was that the local user was not a member of the LDAP user's 
default group.

I corrected these inconsistencies such that the local user's default 
group is the same as the LDAP one and the problem went away.

So, move along... Nothing to see here.

At some point soon I intend to point dovecot at my LDAP server to get 
user information and remove the local user altogether.


More information about the test mailing list