f18 i386 installer memory requirements

Frantisek Hanzlik franta at hanzlici.cz
Wed Jan 9 08:00:50 UTC 2013


John Reiser wrote:
> On 01/08/2013 04:47 PM, Frantisek Hanzlik wrote:
>> i'm trying install f18 on older i686 machine (1.8GHz P4 CPU/512 MB
>> RAM/160 GB HDD/Radeon 9000 64MB graphics), doing NFS graphical
>> installation with XFCE desktop (and several add-ons groups).
>> Installation started from installation CD (images/boot.iso image),
>> anaconda 18.37.8. Install CD Media check is fine.
>> Machine always stop respond in "Checking software dependencies..."
>> phase; CD-ROM permanently rotate and it's all.
>>
>> I suspect this may be caused by insufficient RAM ...
> 
> If you have concerns about RAM, then your first attempt should be
> with no add-on groups.  Or, if you do try add-ons but run into trouble
> then you should try again without the add-ons.
> 
> I just tried Fedora-18-Final-RC2-i386-DVD after converting to USB2,0
> using livecd-iso-to-disk.  My 1.6GHz machine has 1GB RAM, but I restricted
> the kernel to 511MB by appending " mem=511m" to the end of the kernel
> command line [note the lower-case 'm'.]  Switching to VT2 after boot
> [type Ctrl-Alt-F2] then "cat /proc/meminfo" showed "MemTotal: 507984 kB",
> so I was running as if only 511MB of RAM.  The graphics card is
> ATI 9250 (9200 PRO) with 128MB.  [Switch back Ctrl-Alt-F6 for graphics.]
> 
> I had no trouble "Checking software dependencies" with either the default
> Gnome3 desktop, or after changing to Xfce desktop.  /proc/meminfo showed:
>   MemFree:        11180 kB
>   Buffers:        32664 kB
>   Cached:        269504 kB
>   SwapTotal:          0 kB
>   Committed_AS:  483308 kB
> and "ps alx | grep anac" showed anaconda with VSZ=219M and RSS=128M.
> I did not continue with actual installation because I didn't want
> my existing boot configuration (grub1, BIOS drives swapped, ...) clobbered.
> I had 2GB of swap space configured by manual partitioning, re-using
> an existing linux-swap(v1) partition; but note that no swap had been
> used yet because SwapTotal: 0 kB.
> 
> So, I would say that 511MB is enough to start actual package installation
> for default Xfce desktop.   [Last spring I installed Fedora 17 default
> Gnome3 desktop complete from USB2.0 using 383MB at 700MHz and kernel boot
> parameter " nomemcheck".  It took 80 minutes versus 17 minutes
> on my 8GB at 3GHz machine.  I estimate DVD would have taken around
> 2.5 hours due to repeated spin-up and paging from squashfs on DVD.]

It seems You are right, I now tried install Xfce with 512 MB RAM and
without any add-ons and this work.
But installation with add-ons and 1GB RAM had only ~ 1800 packages,
which isn't too - on previous releases I routinely had installations
with 3000-3500 RPM packages.



More information about the test mailing list