swap space in fstab not honoured in Fedora 20 (pre-alpha something)

nonamedotc nonamedotc at fedoraproject.org
Mon Sep 16 16:40:08 UTC 2013


On 09/16/2013 11:11 AM, Clyde E. Kunkel wrote:
> On 09/15/2013 03:11 PM, nonamedotc wrote:
>> Is anyone else seeing the following problem?
>>
>> Swap space in  Fedora 20 is not detected.
>>
>> /etc/fstab
>>
>> /dev/mapper/luks-UUID2 /                       ext4
>> defaults,x-systemd.device-timeout=0 1 1
>> UUID=UUID-BOOT         /boot                   ext4 defaults        1 2
>> /dev/mapper/luks-UUID1 swap                    swap
>> defaults,x-systemd.device-timeout=0 0 0
>>
>> /etc/crypttab
>> luks-UUID1 UUID=UUID1 none
>> luks-UUID2 UUID=UUID2 none
>>
>> If I type swapon -s - it shows nothing. But if I do swapon -a and then
>> check, swap is used.
>>
>> # swapon -a
>>
>> # swapon -s
>> Filename                Type        Size    Used    Priority
>> /dev/dm-1                                  partition    7810044 0    -1
>>
>>
>> These files are almost identical (except UUIDs) in my F19 setup where
>> everything is normal. Any ideas?
>>
>> Also, this seems to happen only when my partitions are encrypted. In my
>> virtual installations, swap seems to be enabled quite fine.
>>
>> Thanks!
>> nonamedotc.
>
>
> Happens also in non-encrypted setups. anaconda-20.16-1.fc20.x86_64
> $ cat /etc/fstab | grep swap
> UUID=c1e73c4a-34f2-4dd5-a472-5cab839aab77 swap                swap 
> defaults  0 0
> $ sudo swapon -s
> $ sudo swapon /dev/sdg5
> $ sudo swapon -s
> Filename                Type        Size    Used    Priority
> /dev/sdg5                                  partition    4095996 0    -1
> $
>
>
>

Reported.
https://bugzilla.redhat.com/show_bug.cgi?id=1008604


More information about the test mailing list