Modesetting failure with kernel 3.15; ok with kernel 3.14

Steven Usdansky usdanskys at gmail.com
Fri Apr 18 22:39:29 UTC 2014


Grabbed a monitor (1600x900 default resolution) that emits a good EDID, and
tried both the 3.13 and 3.15 kernel with no xorg.conf or xorg.conf.d files.
Kernel-3.13 worked as expected - X came up at 1600x900. Kernel 3.15 failed
to modeset; X came up at 1280x1024 (not sure if it was really 1024, but
that what xrandr claimed)


On Thu, Apr 17, 2014 at 1:26 PM, Steven Usdansky <usdanskys at gmail.com>wrote:

> Not sure where to report this problem (or what I should be looking for),
> but when booting any of the 3.15 kernels, kernel-modesetting fails and X
> comes up with a resolution of  1024x768, rather than the 1680x1050
> resolution specified in my xorg.conf file. xorg.conf is necessary because
> my monitor does not emit a proper EDID.
>
> ~$ uname -r
> kernel-3.15.0-0.rc1.git1.1.fc21.x86_64
> ~$ lspci | grep 9100
> 02:00.0 VGA compatible controller: NVIDIA Corporation C78 [GeForce 9100]
> (rev a2)
>
> Reverting to kernel -3.13.7-200.fc20.x86_64 avoids the problem (and
> problems I've been having with firefox-28 locking up with 3.14 kernels).
>
> --
> RockDoctor
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.fedoraproject.org/pipermail/test/attachments/20140418/37c928ae/attachment.html>


More information about the test mailing list