fedup failure from F19->F20

Rick Stevens ricks at alldigital.com
Fri Apr 25 17:12:55 UTC 2014

Hi, gang.

I ran into a nasty trying to upgrade one of my machines from F19 to F20.
Two other machines upgraded without issues, but this one is rather

I did an initial "fedup --network 20" on the F19 box and ran into the
famous google-chrome repo issue, so I reran it with a
"--disablerepo=google-chrome". That went fairly well until the upgrade
check determined that I needed another measly 10M in /boot. So I went
in and cleaned up some old kernels, initrds and such in /boot and freed
up 55M of space in there.

I reran the "fedup --network --disablerepo=google-chrome 20" and 
everything went pretty well until the very end. Now I'm getting this:

updates/20/x86_64/group                                  | 1.6 MB 
finding updates 75% [=========================================== 
Downloading failed: failure: 
from _local: [Errno 256] No more mirrors to try.
[Errno 14] curl#37 - "Couldn't open file 

No, that file does NOT exist in /var/lib/yum/plugins/local/repodata.
There are others in there, but not that specific one.

Rerunning the command keeps coming up with that same error. "fedup 
--clean" doesn't help (get the same error).

I'm afraid this machine is now in a very sick state and I'm petrified
that, should I lose power or something else happens that will cause it
to reboot, it's going to be dead.

I have backups of the machine, but jeeze! Any ideas on what to do?
I'm posting this to the test list because this seems to be more of a
potential issue for future upgrades. If I should post this to the other
lists, please let me know.

Thanks for any assistance you can offer!
- Rick Stevens, Systems Engineer, AllDigital    ricks at alldigital.com -
- AIM/Skype: therps2        ICQ: 22643734            Yahoo: origrps2 -
-                                                                    -
-  What's small, yellow and very, VERY dangerous?  The root canary!  -

More information about the test mailing list